1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Won't start

Discussion in '2nd Gen Tundras (2007-2013)' started by Toyota77, Feb 10, 2017.

  1. Feb 10, 2017 at 1:47 PM
    #1
    Toyota77

    Toyota77 [OP] New Member

    Joined:
    Feb 10, 2017
    Member:
    #6299
    Messages:
    1
    Gender:
    Male
    So I was driving the other day and turned a corner and my truck just dies. Tried to start it and it would turn over but not fire. My check engine light was on before it died and now it's off and there is no power to the OBDll port. Would the ignition switch have anything to do with it or is it the ECM
     
  2. Feb 17, 2017 at 8:50 AM
    #2
    Nyconickk

    Nyconickk New Member

    Joined:
    Jan 21, 2017
    Member:
    #6043
    Messages:
    18
    Gender:
    Male
    First Name:
    Nick
    Vehicle:
    2010 crewmax
    Full exhaust, intake
    Hate to state the obvious, have you checked fuses? Has anything electrical been installed/repaired recently?
    Have you checked for fuel pressure at the rail?
    How many miles on the truck?
     
  3. Feb 17, 2017 at 9:12 AM
    #3
    Nor7

    Nor7 Chilton Manual Guy

    Joined:
    Oct 19, 2015
    Member:
    #1989
    Messages:
    1,318
    Gender:
    Male
    Texas
    Vehicle:
    2007 Tundra Limited CM, 5.7L
    Might want to have the alternator checked. See if you can get it running with a jump start, and if it dies when you disconnect the cables, its your alternator.
     
    Frkypunk and RowdyRon like this.
To Top