1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Wireless CarPlay for those with 2020's...

Discussion in 'Audio & Video' started by trd.james, Jun 17, 2020.

  1. Jun 28, 2020 at 2:58 PM
    #31
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    I was hoping to install it and hide it under the console, but I can't do that if I have to take the thing out of the truck every time I need to check for a firmware update.
     
  2. Jun 28, 2020 at 3:07 PM
    #32
    PWMDMD

    PWMDMD New Member

    Joined:
    Nov 4, 2018
    Member:
    #21332
    Messages:
    323
    Worcester, MA
    Vehicle:
    2020 Tundra Platinum
    I just start the truck, let my phone connect and go to the website and it automatically checks the version and updates it if needed. Super simple....
     
  3. Jun 28, 2020 at 4:16 PM
    #33
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Yes, like @PWMDMD said, you just hit the 'update' button while the dongle is plugged into your truck and all connected. Once you remove from the truck, you won't be able to update it.
     
  4. Jun 28, 2020 at 4:26 PM
    #34
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    OK, thanks. The instructions actually tell you NOT to do this! Told you my ChinEnglish was bad!
     
  5. Jun 28, 2020 at 4:28 PM
    #35
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Which version did you buy? You have an update that mine is not showing. That’s interesting.
    also curious...do you have a blue border around the maps when you first boot up to the CarPlay Dashboard ?
     
  6. Jun 28, 2020 at 5:47 PM
    #36
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    I only installed it this afternoon and have sat in my truck running it for about 15 minutes. No blue border. I got the Audi version from Amazon. I don't remember seeing a firmware version number, just that it saw an upgrade when I prompted it to check. I'll have to report back on any issues, including the blue border.
     
  7. Jun 28, 2020 at 6:09 PM
    #37
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Thanks. That’s the one I got too but something is different. You can see in your screen shot of the update screen that it says “version” and a date. the date in my screen is March 18 and it says that I have the most recent firmware installed.
    So ours are not matching up, yours is pulling an update that mine isn’t which is weird.
    And that might explain the blue border but I don’t know. I continue to have that problem.
     
  8. Jun 28, 2020 at 7:27 PM
    #38
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    OK - I see it now. It was fainter and I just read right over it.
     
  9. Jun 29, 2020 at 4:49 AM
    #39
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White
    I picked up the Audi version on Amazon this week and the firmware version was up to date. The thing I find strange is the pricing on Amazon. I first put one on my wish list and a week later it was out of stock for $129. I do a search and now it $149 with a $20 coupon. The other thing was 1-3 weeks shipping at $129 but 4 day shipping at $149. It might be different products that sound like the same name. Carlinkit 2.0 is what I picked up and seems to work great so far.
     
  10. Jun 29, 2020 at 6:05 AM
    #40
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Do you happen to know which firmware version you have?
    Are you experiencing the 'blue outline' around the maps portion of the Dashboard when you first start your truck?
     
  11. Jun 29, 2020 at 6:05 AM
    #41
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Mine finally prompted for the update this morning but keeps giving me the message "update failed". I think I just might have a buggy one. Starting to wonder how long these things will last...
     
  12. Jun 29, 2020 at 6:25 AM
    #42
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    I did not notice any blue outline this morning coming to work. You might want to see about swapping yours out.
     
  13. Jun 29, 2020 at 6:26 AM
    #43
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Thanks for the reply. I think I will try and swap it, especially considering the Update failed.
     
  14. Jun 29, 2020 at 7:48 AM
    #44
    PWMDMD

    PWMDMD New Member

    Joined:
    Nov 4, 2018
    Member:
    #21332
    Messages:
    323
    Worcester, MA
    Vehicle:
    2020 Tundra Platinum
    Mine did something similar in the beginning and it had something to due with WIFI....when I tried it away from the house it worked fine.
     
  15. Jun 29, 2020 at 7:58 AM
    #45
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White

    I do not remember seeing any blue outline but will look for it the next time I take the Tundra. I did not pay attention to the firmware revision because it said it was up to date. I can try it again and see if I can capture it on my phone.
     
  16. Jun 29, 2020 at 11:18 AM
    #46
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White
    Mine did not have any blue lines. It also needs a firmware update which I tried and it failed. I will have to take a pencil and sheet of paper to write down the version. I did a IOS update last night so that might be why it failed.
     
  17. Jun 29, 2020 at 11:25 AM
    #47
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Mine is just all around screwed up. It failed the update and now will not even connect my iPhone to the truck any more.
     
  18. Jun 29, 2020 at 11:48 AM
    #48
    NuTundra18

    NuTundra18 New Member

    Joined:
    Jan 1, 2020
    Member:
    #40578
    Messages:
    103
    Gender:
    Male
    First Name:
    Jimmy
    Florida
    Vehicle:
    2020 TRD Pro CM - MGM
    Toyota OEM Hard Flip Tonneau, Predator Steps, Driver Grab Handle, Console Sage, Spray Berliner.
    Mine works when connected but update keeps failing. Not sure if it’s a WiFi issue or Bluetooth issue. Not sure if Bluetooth should be on when updating. I even disconnected from home WiFi so wouldn’t have the issue. Pain the the ass!
     
  19. Jun 29, 2020 at 2:18 PM
    #49
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White

    That is exactly the same problem that I am having. Tried every which way and still no update. Just Failed to Update and reboot on the screen. The LEDs will flash red and then it will turn on the blue and flash every couple of seconds but that just seems to tell you that you are connected. The version it is trying to update to is 2020.06.17.0549 and the size is 6.06MB
     
  20. Jun 29, 2020 at 4:37 PM
    #50
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Yep that is what was happening to me too. Then it stopped working entirely.
    What phone versions do you guys have? I’m trying to figure out my blue line issue.
    I’m using an 11 Pro.
    I just tried using the dongle in a Jeep with CarPlay and got the same blue border.
    Since it seems like no one else here gets that, I think it may be my phone.
     
    Last edited: Jun 29, 2020
  21. Jun 29, 2020 at 4:56 PM
    #51
    1794-BlackTundra

    1794-BlackTundra New Member

    Joined:
    Sep 18, 2018
    Member:
    #19534
    Messages:
    205
    Gender:
    Male
    First Name:
    Sergio
    Vehicle:
    2019 Black Tundra 1794 Edition CM
    Rhino Linings, Smittybilt 11500 Winch (Internal), BAKflip MX4, RotopaX, MaxTrax, ARB Simpson III tent, Old Man Emu suspension, TRD rims, Pioneer Platform with Rhino-Rack Backbone System
  22. Jun 30, 2020 at 4:13 AM
    #52
    kxed

    kxed New Member

    Joined:
    Oct 13, 2019
    Member:
    #37314
    Messages:
    19
    Gender:
    Male
    Pittsburgh PA
    Vehicle:
    2020 VooDoo Blue Crewmax Sport
    carplay2air is on sale for 129.95
     
  23. Jun 30, 2020 at 5:57 AM
    #53
    NuTundra18

    NuTundra18 New Member

    Joined:
    Jan 1, 2020
    Member:
    #40578
    Messages:
    103
    Gender:
    Male
    First Name:
    Jimmy
    Florida
    Vehicle:
    2020 TRD Pro CM - MGM
    Toyota OEM Hard Flip Tonneau, Predator Steps, Driver Grab Handle, Console Sage, Spray Berliner.
    Looks like you and I are experiencing same damn issue.
     
  24. Jun 30, 2020 at 5:58 AM
    #54
    NuTundra18

    NuTundra18 New Member

    Joined:
    Jan 1, 2020
    Member:
    #40578
    Messages:
    103
    Gender:
    Male
    First Name:
    Jimmy
    Florida
    Vehicle:
    2020 TRD Pro CM - MGM
    Toyota OEM Hard Flip Tonneau, Predator Steps, Driver Grab Handle, Console Sage, Spray Berliner.
    I have a 10 XS
     
    trd.james [OP] likes this.
  25. Jun 30, 2020 at 6:10 AM
    #55
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White
    I have a 10X Max and just updated to the latest IOS. I guess I am not going to try to update mostly cause it seems to work just fine. I plan on explaining all of this in a Amazon review with hopes that they will fix the update problem and add clear instructions.
     
    trd.james [OP] and Bakershack like this.
  26. Jun 30, 2020 at 9:49 AM
    #56
    trd.james

    trd.james [OP] New Member

    Joined:
    May 7, 2020
    Member:
    #46130
    Messages:
    86
    Gender:
    Male
    First Name:
    James
    2020 TRD PRO | Westcott Lift | 35" KO2's
    Update: Mine is working again. Still have the blue outline issue but maybe not as much...hard to say. I'm happy it's working and I'm leaving the update alone for now.
    Thanks for the phone model info.
     
  27. Jul 2, 2020 at 3:59 AM
    #57
    jrquist

    jrquist New Member

    Joined:
    Aug 3, 2019
    Member:
    #34078
    Messages:
    41
    Gender:
    Male
    Carlton, Minnesota
    Vehicle:
    2020 Tundra SR5 Sport Bright White
    So I received an email from Amazon letting me know my review was now posted. Went to look for it by searching for Carlinkit 2.0 and was not able to see my review. I went to my orders and clicked on the unit I bought and now could see my review. I am guessing there are a couple of different versions of this product even thou they seem all the same but the prices and write ups are different. Might be why some act different then others when booting up. I see that mine is still $149 and this is what the top of the description look like:

    Carlinkit 2.0 carplay dongle Wired to Wireless activator Adapter for Audi Volvo Benz Porsche Hyundai OEM Stereo with carplay/Support iOS13
     
  28. Jul 2, 2020 at 8:02 AM
    #58
    NuTundra18

    NuTundra18 New Member

    Joined:
    Jan 1, 2020
    Member:
    #40578
    Messages:
    103
    Gender:
    Male
    First Name:
    Jimmy
    Florida
    Vehicle:
    2020 TRD Pro CM - MGM
    Toyota OEM Hard Flip Tonneau, Predator Steps, Driver Grab Handle, Console Sage, Spray Berliner.
    By the way, I was having issues updating mine after multiple failure; however, after leaving my house it appears to have updated on its own a day later as now it says I have the most up to date software version. Still seems to be working after a few days now. I do have that funky white Toyota app but no blue line surrounding map etc.
     
    trd.james [OP] likes this.
  29. Jul 2, 2020 at 1:44 PM
    #59
    Brlowe

    Brlowe New Member

    Joined:
    Jun 13, 2020
    Member:
    #47930
    Messages:
    67
    Gender:
    Male
    Idaho
    Vehicle:
    2020 Calvary Blue Tundra Limited 4x4
    My CPlay2Air says it is up to date and I have the same white Toyota app button. Other than that it work great.
     
  30. Jul 4, 2020 at 11:38 AM
    #60
    Bakershack

    Bakershack Critical of Noncritical Thinkers

    Joined:
    May 20, 2020
    Member:
    #46846
    Messages:
    133
    Gender:
    Male
    First Name:
    Kelly
    Spanish Fort, AL
    Vehicle:
    2020 Silver Sky Metallic Tundra 1794 Edition
    I installed mine under the console this morning with the 9" 90 degree USB extension cable from Amazon. Now I have my space back and I don't have to plug my phone into the truck for anything! I used my trusty hand file to etch out a notch for the cable. I left enough slack to unplug it if I need to. Even if this doesn't work out and I have to remove the whole thing, that notch is invisible once the console is installed.
    IMG_5600.jpg IMG_5601.jpg IMG_5603.jpg IMG_5607.jpg IMG_5605.jpg IMG_5606.jpg
     
    jrquist and trd.james [OP] like this.

Products Discussed in

To Top