1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Turn Signals not Working

Discussion in '2nd Gen Tundras (2007-2013)' started by 650h1, Mar 30, 2014.

  1. Mar 30, 2014 at 12:16 PM
    #1
    650h1

    650h1 [OP] New Member

    Joined:
    Jan 7, 2014
    Member:
    #51
    Messages:
    560
    Gender:
    Male
    Vehicle:
    2013 Rock Warrior C/M
    So... I turned my signals on this morning, and noticed it was hyper flashing. Turned other signal on to check, also hyper flashing. Checked all fuses in the interior and under the hood, they are good, not blown. Weird thing is that my DRL's still work, they just won't flash when I hit the blinkers. Any thoughts?
     
  2. Mar 30, 2014 at 5:25 PM
    #2
    Beer'd_n_yotas

    Beer'd_n_yotas New Member

    Joined:
    Jan 7, 2014
    Member:
    #47
    Messages:
    102
    Gender:
    Male
    Vehicle:
    2013 Super White Tundra
    Plasti-dipped and lowered!
    Sounds like your flasher might need to be replaced.
     
  3. Mar 30, 2014 at 5:36 PM
    #3
    ThemAster

    ThemAster New Member

    Joined:
    Mar 19, 2014
    Member:
    #303
    Messages:
    65
    Gender:
    Male
    First Name:
    Morpheus
    What he ^^^ said and you probably may have a blown bulb. In the mean time, stick your hand out like the good old days. :wave:
     
    NewImprovedRon, YeeYeeTundra and Bob like this.
  4. Mar 30, 2014 at 7:22 PM
    #4
    650h1

    650h1 [OP] New Member

    Joined:
    Jan 7, 2014
    Member:
    #51
    Messages:
    560
    Gender:
    Male
    Vehicle:
    2013 Rock Warrior C/M
    Hahaha where is the flasher? I couldn't find the fucker all day....
     
    GNTundra likes this.
  5. Mar 30, 2014 at 7:25 PM
    #5
    Beer'd_n_yotas

    Beer'd_n_yotas New Member

    Joined:
    Jan 7, 2014
    Member:
    #47
    Messages:
    102
    Gender:
    Male
    Vehicle:
    2013 Super White Tundra
    Plasti-dipped and lowered!
    I have no clue!
     
  6. Mar 30, 2014 at 9:08 PM
    #6
    650h1

    650h1 [OP] New Member

    Joined:
    Jan 7, 2014
    Member:
    #51
    Messages:
    560
    Gender:
    Male
    Vehicle:
    2013 Rock Warrior C/M
    Hmm.. It's still under warranty, I just don't wanna deal with the ship if I don't have to..
     
  7. Mar 30, 2014 at 9:15 PM
    #7
    csuviper

    csuviper Moderator Staff Member

    Joined:
    Jan 6, 2014
    Member:
    #38
    Messages:
    16,271
    Gender:
    Male
    First Name:
    Brian
    Broomfield, CO
    Vehicle:
    2019 TRD Sport CM 5.7L 4X4
    Some Mods :) See build thread for details
    Def a bulb out. Could be rear.
     
  8. Mar 31, 2014 at 8:34 AM
    #8
    650h1

    650h1 [OP] New Member

    Joined:
    Jan 7, 2014
    Member:
    #51
    Messages:
    560
    Gender:
    Male
    Vehicle:
    2013 Rock Warrior C/M
    Both rear signals work... They flash fast right now. Neither front signals work is the issue.
     
  9. Mar 31, 2014 at 10:27 AM
    #9
    csuviper

    csuviper Moderator Staff Member

    Joined:
    Jan 6, 2014
    Member:
    #38
    Messages:
    16,271
    Gender:
    Male
    First Name:
    Brian
    Broomfield, CO
    Vehicle:
    2019 TRD Sport CM 5.7L 4X4
    Some Mods :) See build thread for details
    look at the front bulbs. Is the filament burned out or gaped for the signals?
     
  10. Mar 31, 2014 at 4:24 PM
    #10
    ThemAster

    ThemAster New Member

    Joined:
    Mar 19, 2014
    Member:
    #303
    Messages:
    65
    Gender:
    Male
    First Name:
    Morpheus
    Its not unusual for both bulbs to burn out at the same time. Perhaps a bad batch. Check them out. Also check the connectors to the lights. You flasher could be near/under the steering column or the fuse box. Check the owners manual.
     
  11. Mar 31, 2014 at 7:49 PM
    #11
    650h1

    650h1 [OP] New Member

    Joined:
    Jan 7, 2014
    Member:
    #51
    Messages:
    560
    Gender:
    Male
    Vehicle:
    2013 Rock Warrior C/M
    Bulbs were burned out. They are double filament and I saw that one filament was good, which happened to be the drl use, but blinkers were blown. So I'm good now lol.
     
  12. Apr 27, 2019 at 6:57 PM
    #12
    Bratch

    Bratch New Member

    Joined:
    Dec 15, 2017
    Member:
    #11536
    Messages:
    14
    Gender:
    Male
    First Name:
    Jimmy
    OK, so I had the same problem today: both front blinkers went out: rears work: hyper flashing on dash.
    Did both of your front bulbs go out at the same time?
    hard to believe.
     
  13. Apr 29, 2019 at 11:44 AM
    #13
    NWExplorer

    NWExplorer this guy

    Joined:
    Mar 29, 2019
    Member:
    #28323
    Messages:
    46
    Gender:
    Male
    First Name:
    Jason
    Washington
    Vehicle:
    2010 CM Platinum 4x4
    Really raising the dead here. :) It's not uncommon. Always better to replace them in pairs anyway.
     
    TXRailRoads73 likes this.
  14. Apr 29, 2019 at 11:47 AM
    #14
    TXRailRoads73

    TXRailRoads73 ROCKIN' N ROLLIN' WITH THE TÜNDRA CRÜE

    Joined:
    May 30, 2016
    Member:
    #3487
    Messages:
    40,355
    Gender:
    Male
    First Name:
    Adam
    The Lone Star State, RGV, TEXAS
    Vehicle:
    2014 CM TSS 4WD SR5 5.7 MGM
    Rough Country 6" lift / 35x12.50R20 Cooper Discoverer ST Maxx/ 20x9 +20 Fuel wheels "Mavericks" (Came with) / S&B CAI/ 2-10" Rockford Fosgates R2/ Massive Audio Nano N2 amp (Came with)/ KatSkins seat covers (Came with)/ Weathertechs window vent visors and floor mats/ 1A-AUTO.com aftermarket tow mirrors/ Undercover tonneau bed cover/ Viper alarm 3305V/ Flowmaster Super 40 Dual in-out/ 40" led light bar/ TRD Pro grille/Rough Country 30" LED light bar/TRD rear sway bar/ Ranch Hand legend grille gaurd/ Nfab nurf bars/ 2019 PRO headlights
    e5101d31d81b39488a4a5ac9af714851.jpg
    Maybe out of Blinker Fluid???:notsure:
     
    georgiey22, GNTundra and NWExplorer like this.
  15. May 8, 2019 at 1:26 PM
    #15
    Bratch

    Bratch New Member

    Joined:
    Dec 15, 2017
    Member:
    #11536
    Messages:
    14
    Gender:
    Male
    First Name:
    Jimmy
    Yeah, that must be it!
     
  16. May 8, 2019 at 1:27 PM
    #16
    Bratch

    Bratch New Member

    Joined:
    Dec 15, 2017
    Member:
    #11536
    Messages:
    14
    Gender:
    Male
    First Name:
    Jimmy
    Actually: it was both bulbs: burnt out at same time.
    Still find that hard to believe; but new bulbs took care of it.
    Thanks everyone.
     
    NewImprovedRon and NWExplorer like this.

Products Discussed in

To Top