1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Truck cranks, runs for a few, the shuts off...2007 5.7

Discussion in '2nd Gen Tundras (2007-2013)' started by oldschoolhdmike, Jul 11, 2016.

  1. Jul 11, 2016 at 3:12 PM
    #1
    oldschoolhdmike

    oldschoolhdmike [OP] New Member

    Joined:
    Jun 4, 2016
    Member:
    #3528
    Messages:
    31
    Gender:
    Male
    First Name:
    mike
    Vehicle:
    2007 tundra crew max 5.7
    not much
    just got home from work and i go to hook up my camper and my truck cranks fine.....runs for about 5-6 seconds and shuts off. does it over and over and now wont even crank. fuel pump? thinking it may have been cranking and running on fuel in the lines? now there is now fuel it wont crank?
     
  2. Jul 11, 2016 at 3:29 PM
    #2
    oldschoolhdmike

    oldschoolhdmike [OP] New Member

    Joined:
    Jun 4, 2016
    Member:
    #3528
    Messages:
    31
    Gender:
    Male
    First Name:
    mike
    Vehicle:
    2007 tundra crew max 5.7
    not much
    ok. i go out about 15 minutes later and it cranks and stays running. so?????? security cpu.....geez i hope not
     
  3. Jul 11, 2016 at 3:31 PM
    #3
    TheBeast

    TheBeast Once you go black...

    Joined:
    Apr 27, 2016
    Member:
    #3246
    Messages:
    1,525
    Gender:
    Male
    SoCal
    Vehicle:
    2012 CM 4x4 TRD
    do you hear the fuel pump kickin in when you turn on the key ?
     
  4. Jul 11, 2016 at 3:36 PM
    #4
    oldschoolhdmike

    oldschoolhdmike [OP] New Member

    Joined:
    Jun 4, 2016
    Member:
    #3528
    Messages:
    31
    Gender:
    Male
    First Name:
    mike
    Vehicle:
    2007 tundra crew max 5.7
    not much
    no but i has been running now for 10 minutes. turned it off again to try and hear the pump and i cannot hear anything....but it has been running now.....now i am afraid of getting stranded. a shop cant tell what it is doing if it wont do it. no check engine light is on
     
  5. Jul 11, 2016 at 3:44 PM
    #5
    Law323

    Law323 Retreat? Hell, we just got here!

    Joined:
    Apr 7, 2016
    Member:
    #3081
    Messages:
    3,397
    Gender:
    Male
    First Name:
    Law
    Tennessee
    Vehicle:
    2012 4.6 L MGM DC
    TOYTEC BOSS suspension lift @ 3" (front) 1" Toytec block (rear) 275/70r18 Toyo AT2 Info system mod 3D MAXpider Kagu floor mats LED interior lights 50% ceramic tint front windows 35% ceramic tint windshield brow Bed mounted YETI bottle opener Paracord wrapped oh Sh!t bars 3" stubby antennae Upcoming: LED backup lights/cargo lights OEM Backup camera Raceline Raptor? 18x9 wheels ICI magnum step bars TRD sway bar Trifold or roll up tonneau cover Tow mirrors????
    Could be electrical??
     
  6. Jul 11, 2016 at 4:08 PM
    #6
    Mike

    Mike Tread lightly.

    Joined:
    Jan 13, 2014
    Member:
    #87
    Messages:
    2,663
    Gender:
    Male
    First Name:
    Mike
    south carolina
    Vehicle:
    2003 tundra sr5 4x4 stepside....
    yep bank account is running low from it..
    Fuel pump,relay to the fuel pump bad, crankshaft sensor not picking up.. or battery connections dirty not making solid connection..
     
  7. Jul 11, 2016 at 4:19 PM
    #7
    oldschoolhdmike

    oldschoolhdmike [OP] New Member

    Joined:
    Jun 4, 2016
    Member:
    #3528
    Messages:
    31
    Gender:
    Male
    First Name:
    mike
    Vehicle:
    2007 tundra crew max 5.7
    not much
    fuel pump relay would be nice. but it wont be my luck
     
  8. Jul 11, 2016 at 4:26 PM
    #8
    ColoradoTJ

    ColoradoTJ Shower beer...because I can.

    Joined:
    Feb 24, 2016
    Member:
    #2766
    Messages:
    4,702
    Gender:
    Male
    First Name:
    McLovin
    Colorado Springs, CO
    Vehicle:
    2016 GMC 3500 Summit White
    Tint, molded mud flaps Gooseneck hitch next.
    Total bummer.

    I would look at what @Mike suggested as well. Relays are cheap and easy to test.
     
  9. Jul 11, 2016 at 4:32 PM
    #9
    Mike

    Mike Tread lightly.

    Joined:
    Jan 13, 2014
    Member:
    #87
    Messages:
    2,663
    Gender:
    Male
    First Name:
    Mike
    south carolina
    Vehicle:
    2003 tundra sr5 4x4 stepside....
    yep bank account is running low from it..
    Rare relays go bad for no reason.. the Toyota fuel pump is a tough pump.. I have 280,000 on mine it's in my Tacoma tho..

    If you know how to use ohms meter. Check for continuity between ground and where the lead going to the fuel pump is on the relay side.. if it reads infinity pump is shot... if it reads continuity pump is good...
     
    ColoradoTJ likes this.
  10. Jul 11, 2016 at 4:36 PM
    #10
    oldschoolhdmike

    oldschoolhdmike [OP] New Member

    Joined:
    Jun 4, 2016
    Member:
    #3528
    Messages:
    31
    Gender:
    Male
    First Name:
    mike
    Vehicle:
    2007 tundra crew max 5.7
    not much
    taking it to my buddy who is going to test that stuff tomorrow...he can also test fuel pressure.....guess i will know more tomorrow
     
  11. Jul 11, 2016 at 7:44 PM
    #11
    Sean266

    Sean266 #ThinBlueLine Staff Member

    Joined:
    Jan 5, 2014
    Member:
    #6
    Messages:
    12,074
    Gender:
    Male
    Colorado
    Hope its minor!
     
  12. Jul 12, 2016 at 12:25 AM
    #12
    4wd

    4wd New Member

    Joined:
    Jul 5, 2016
    Member:
    #3783
    Messages:
    28
    Gender:
    Male
    First Name:
    Doug
    Vehicle:
    currently truckless
    I don't know if Tundras use igniters but if so dbl check harness connections, they can seem tight but as I found out is not always true...
     
  13. Feb 18, 2017 at 4:59 PM
    #13
    Wes07

    Wes07 New Member

    Joined:
    May 9, 2016
    Member:
    #3328
    Messages:
    17
    Gender:
    Male
    First Name:
    Wes
    Colorado Springs
    Vehicle:
    07 tundra
    Reviving an old thread, my 07 5.7 does this almost weekly now but cranks on the 5th try every time. It has went into limp mode once after cranking it after driving it hard in an emergency. Would this be the aip or crank position sensor?
     
  14. Feb 18, 2017 at 7:00 PM
    #14
    GNTundra

    GNTundra Troll Sniper

    Joined:
    Sep 14, 2016
    Member:
    #4536
    Messages:
    1,600
    Gender:
    Male
    First Name:
    Gino
    Kansas
    Vehicle:
    2013 CrewMax SR5 Louisiana Edition
    Procomp Stage 2 6" 20x12 Fuel Mavericks 35x12.50x20 Nittos
    How many miles? Id bet on CS sensor :notsure:
     
  15. Feb 18, 2017 at 9:09 PM
    #15
    Wes07

    Wes07 New Member

    Joined:
    May 9, 2016
    Member:
    #3328
    Messages:
    17
    Gender:
    Male
    First Name:
    Wes
    Colorado Springs
    Vehicle:
    07 tundra
    160k. I unhooked the positive battery cable and that cured the limp mode.
     
To Top