1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

problem with my 2006 tundra 4.7l

Discussion in 'New Member Introductions' started by Bandit123, Feb 24, 2020.

  1. Feb 24, 2020 at 11:30 AM
    #1
    Bandit123

    Bandit123 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43090
    Messages:
    0
    Gender:
    Male
    First Name:
    Colin
    Vehicle:
    tundra 2006
    Vehicle Modifications:
    0
    Starts well in cold weather, but when it has been running, then shut if off for 1 to 2 hours, the engine rolls over a extra 3 to 5 more times before it actually fires up.
    Fuel tank was cleaned and new fuel pump because pressure was low
    and at end of 2019 changed all injectors because dealer said that should be it.
    They installed them and it seemed to be working, but now the weather is getting warmer its starting to do it again.
    Dealer thinks its the parts I got, but they are OEM genuine new parts, just I didn't order from them. I think there is a underlying problem.
    Hope someone can help
     
  2. Feb 24, 2020 at 11:32 AM
    #2
    Hbjeff

    Hbjeff New Member

    Joined:
    Jan 20, 2019
    Member:
    #24845
    Messages:
    3,666
    Gender:
    Male
    Huntington Beach
    Vehicle:
    2010 DC tundra lame-o 2wd
    How many miles?
     
  3. Feb 24, 2020 at 1:13 PM
    #3
    koditten

    koditten New Member

    Joined:
    Apr 6, 2018
    Member:
    #14241
    Messages:
    853
    Gender:
    Male
    Sure sounds like leaky injector(s).
     

Products Discussed in

To Top