1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

New truck same issues

Discussion in '3rd Gen Tundras (2014-2021)' started by Kstundra81, Mar 9, 2020.

  1. Mar 9, 2020 at 9:31 AM
    #1
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    So my 07 limited tundra that started screeching when I would cold start it. Just for the start then it wouldn't screech any more, and ran fine. Then it started clicking like the battery was dead then screeching at me. Of course it only does this from time to time not every start. I put it in the shop and it never happened to them once. They replaced the starter just to get my money I think. Anyhow, I traded it in for a 2014 platinum tundra model this weekend. Guess what happened I started it this morning. Same thing click click click click start screech. Runs fine. Any ideas.??? The battery looks like it is the original. 2014 date on it. Good place to start and replace it?
     
    NewImprovedRon likes this.
  2. Mar 9, 2020 at 9:49 AM
    #2
    Fotnot

    Fotnot SSEM #69

    Joined:
    Feb 28, 2019
    Member:
    #26821
    Messages:
    1,879
    Gender:
    Male
    First Name:
    Andy
    SW Louisiana
    Vehicle:
    2021 Sequoia TRD PRO Lunar Rock
    have battery checked before replacing...but seems like potential to need to change. the screeching sounds like something like a belt thats cold. not sure where you live if it's cold or not,but that may be contributing to it
     
    Rica25 likes this.
  3. Mar 9, 2020 at 10:09 AM
    #3
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    Live in Kansas its still been a little cool her at nights but the weekend wasn't so bad. I thought the problem was a belt last time (in the 07) I changed it. No difference. Also changed the starter and no difference. Plus the battery in it was new in December last year
     
    Rica25 likes this.
  4. Mar 9, 2020 at 10:38 AM
    #4
    toyofan87

    toyofan87 Beer thirty

    Joined:
    Mar 8, 2020
    Member:
    #43653
    Messages:
    756
    Gender:
    Male
    First Name:
    Seth
    Gettysburg, Penna
    Vehicle:
    80- LB...87 4Runner--Tundra
    Toytec 2.0 Aluma 3/1.5 lift with JBA's UCA.
    Those platinums are solid trucks..Good luck.
     
    Rica25 likes this.
  5. Mar 9, 2020 at 10:44 AM
    #5
    Crunch527

    Crunch527 Brute Force and Ignorance

    Joined:
    Nov 1, 2016
    Member:
    #5049
    Messages:
    560
    Gender:
    Male
    Iowa
    TRD Supercharger/BAM
    I just replaced my 2014 batt...went with a OEM replacement...if you have the original batt its prolly time.
     
    Rica25 and 15whtrd like this.
  6. Mar 9, 2020 at 10:50 AM
    #6
    Toytock

    Toytock New Member

    Joined:
    Apr 14, 2019
    Member:
    #29083
    Messages:
    11
    Gender:
    Male
    First Name:
    Jeremy
    ND
    Vehicle:
    2015 Tundra TRD Pro
    My alternator squeals when it's cold, so far anything below 20f and she howls for a min, once it warms up a little, it quiets.
     
    Rica25 likes this.
  7. Mar 9, 2020 at 10:53 AM
    #7
    15whtrd

    15whtrd Mr. Blonde

    Joined:
    Sep 20, 2015
    Member:
    #1829
    Messages:
    9,362
    Gender:
    Male
    First Name:
    Sean
    SoCal
    Vehicle:
    White 2015 Tundra DC SR5 TRD 4x4 5.7L, White 2003 Sequoia 2WD
    TRD Pro suspension, +2 Coachbuilder shackles, 2015 TRD Pro headlights, 20% ceramic tinted windows, clear ceramic tinted front windshield, aFe drop in pro s dry air filter, TRD airflow accelerator, TRD oil fill cap, TRD 18 psi radiator cap, BDX Bullydog tuner, Weathertech floor mats front and rear, rear seat fold down mod, DNA hard trifold tonneau cover, Linex with uv protection, TRD rear swaybar, TRD center caps, TRD Pro grille insert with color matching surround and bulge, TRD PRO headlights, aluminum oil filter canister, Real truck tailgate seal, Pop-n-lock tailgate lock actuator, rear diff breather relocate, RCI front skid plate. 275/70 R18 BFG KO2s
    It’s a six year old battery. It’s time anyway
     
  8. Mar 9, 2020 at 10:53 AM
    #8
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    When yours squeals at you does it ever hinder the start? Mine is just one short screech or a bunch of clicks followed by the screech
     
    Rica25 likes this.
  9. Mar 9, 2020 at 10:53 AM
    #9
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    Yeah for sure.. It will be changed tonight
     
    Rica25 likes this.
  10. Mar 9, 2020 at 10:56 AM
    #10
    Toytock

    Toytock New Member

    Joined:
    Apr 14, 2019
    Member:
    #29083
    Messages:
    11
    Gender:
    Male
    First Name:
    Jeremy
    ND
    Vehicle:
    2015 Tundra TRD Pro
    Nah. She's loyal and always starts. Can't speak about the clicks and no start condition. Even at -30f she pops off, a little grumpy, but who isnt at that temp.
     
    HailstorminMT likes this.
  11. Mar 9, 2020 at 11:04 AM
    #11
    Cavalrysr5

    Cavalrysr5 New Member

    Joined:
    Mar 8, 2020
    Member:
    #43693
    Messages:
    190
    Gender:
    Male
    First Name:
    Jared
    Vehicle:
    2020 tundra cavalry blue sr5
    Cold belt/alternator needing to charge so the bel slips. My camaro does this every once in a while when it has a heavy draw on the alternator(such as a cold battery the alt is trying to charge)
     
    15whtrd likes this.
  12. Mar 9, 2020 at 3:59 PM
    #12
    HulkSmurf14

    HulkSmurf14 ...Weighted Average...

    Joined:
    Aug 9, 2019
    Member:
    #34377
    Messages:
    848
    Gender:
    Male
    Vehicle:
    2014 Tundra Limited
    Tastefully enhanced...
    Belt tensioner chirp for a bit too when cold...it is a mild short-coming to the 2nd and early 3rd gens...something to consider on top of the battery...
     
  13. Mar 9, 2020 at 4:48 PM
    #13
    truckguy84

    truckguy84 New Member

    Joined:
    Jan 8, 2020
    Member:
    #40899
    Messages:
    81
    Gender:
    Male
    Vehicle:
    2011 Black Tundra SR5 TRD
    Yeah I would replace that battery for sure. They only last so long.
     
  14. Mar 9, 2020 at 4:56 PM
    #14
    CTPlatinum

    CTPlatinum New Member

    Joined:
    Dec 26, 2019
    Member:
    #40344
    Messages:
    97
    Gender:
    Male
    Vehicle:
    2020 Tundra Platinum 4x4
    None Yet
    Go to Napa or O'Reily's and buy yourself a can of belt dressing for $2 and replace your battery. Job done in under 15 minutes and less than $100.
     
  15. Mar 9, 2020 at 5:36 PM
    #15
    DSLKSL

    DSLKSL New Member

    Joined:
    Jan 1, 2017
    Member:
    #5752
    Messages:
    66
    Gender:
    Male
    First Name:
    Don
    Vehicle:
    2016
    My 2007 did the screech on a cold start for only 5 seconds. I took it to the dealer and told them to listen when someone else starts it.....they didn't. So I said leave it overnight again and 1st thing in the morning open the hood and stick you head in there while you get some one else to start it...They did, change the idler pulley and belt because the belt split lengthwise from drawing on the pulley. The click click is just a 6 year old crapy Toyota battery.
     
    snivilous and HulkSmurf14 like this.
  16. Mar 9, 2020 at 6:02 PM
    #16
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    So i checked the battery before I started it this evening it was just over 12. It didn't start just clicked then died. It barely started the second time. Showed high 12s when it did start. I went right to get a new battery. New one registered 13.8 while running when I got home and 12.9 when I shut it off
     
    15whtrd likes this.
  17. Mar 10, 2020 at 3:09 PM
    #17
    Tundra14Platinum

    Tundra14Platinum New Member

    Joined:
    Sep 24, 2019
    Member:
    #36582
    Messages:
    366
    Gender:
    Male
    Florida
    Vehicle:
    2014 Tundra Platinum CM Sky Silver
    TRD Swaybar, Eibach, TRD PRO Grill/Headlights
    I had oem battery, did the same thing when it was cold, cold for FL 50*. Spent the $$$ in the group buy for the Northstar battery. Runs great, no click click click. starts right up. No you don't need a Northstar battery but get a good one.
     
  18. Mar 10, 2020 at 6:59 PM
    #18
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    I got the best O'Riley's had to offer last night. Also bought a multi meter. Been testing it running and shut off and it seems to be going great so far. 13.9 when running and 12.7 shut off. I think it was 12.6 this morning but it was also 30 degrees last night where I live. But she started right up. Now im pretty sure I traded in my 07 because a battery lol. But its all good I got a 14 platinum with way lower miles out of it
     
  19. Mar 10, 2020 at 7:01 PM
    #19
    Tundra14Platinum

    Tundra14Platinum New Member

    Joined:
    Sep 24, 2019
    Member:
    #36582
    Messages:
    366
    Gender:
    Male
    Florida
    Vehicle:
    2014 Tundra Platinum CM Sky Silver
    TRD Swaybar, Eibach, TRD PRO Grill/Headlights
    You got pic's of this 14 Platinum?
     
  20. Mar 10, 2020 at 7:05 PM
    #20
    snivilous

    snivilous New Member

    Joined:
    Apr 16, 2019
    Member:
    #29192
    Messages:
    1,254
    SW UT
    Vehicle:
    250k Supercharged 2008
    Squeal is either belt or a pulley, most likely the idler pulley.
     
  21. Mar 10, 2020 at 7:57 PM
    #21
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
  22. Mar 10, 2020 at 8:00 PM
    #22
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    I read somewhere that when there isn't enough amps from the battery to give the alternator a good pull in the start it could cause the belt to squeal.
     
    Rica25 likes this.
  23. Mar 10, 2020 at 8:28 PM
    #23
    Dalandshark

    Dalandshark Infected with 5G

    Joined:
    Feb 22, 2020
    Member:
    #43002
    Messages:
    502
    Gender:
    Male
    Northwest
    Vehicle:
    2007 Tundra SR5 5.7 Longbed
    Eibach Level LIft
    Another vote for the idler pulley. My 03 4.7l 4runner has been doing it for 6 years. Also, the battery for the runner was less at the dealer by a good 50 bucks (than Napa, Orielly, AutoZone).
     
  24. Mar 10, 2020 at 8:30 PM
    #24
    Rica25

    Rica25 Got Bam? IG ......@TNDRA08

    Joined:
    Dec 6, 2017
    Member:
    #11380
    Messages:
    5,388
    Gender:
    Male
    First Name:
    Ricardo
    Tulare
    Vehicle:
    2008 Super White Tundra/14 Cement FJ
    TRD sway bar...addictive audio sub woofer.....Volant intake.....Black Rhino Glamis wheels....Billstein adjustable shocks
    Mine squealed I have 2008 and it was the serpentine belt tensioner got it replaced and good to go
     
  25. Mar 10, 2020 at 9:01 PM
    #25
    Kstundra81

    Kstundra81 [OP] New Member

    Joined:
    Feb 24, 2020
    Member:
    #43081
    Messages:
    29
    Gender:
    Male
    Vehicle:
    Black 2014 platinum
    None
    About 2 years ago I had the tensioner replaced. It Did make the belt squeal as it shredded it. Thought it may have been that this time so I replaced the belt and checked the tensioner again. It was good. Squeel was different. Was a 1/4 second screech right as it cranked over and then stopped. I'm fairly certain now it was due to not having the amps it needed and making the alternator screech. It all went away with new battery
     

Products Discussed in

To Top