1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Limp mode in 07 Tundra limited

Discussion in '2nd Gen Tundras (2007-2013)' started by Formerchevyman, Feb 23, 2020.

  1. Feb 23, 2020 at 1:28 PM
    #1
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    So today my tundra went into limp mode for the first time. Luckily, I had read a lot about it on this forum prior to it happening so I knew how to clear it. Now.... what I’m looking at doing is buying a bypass kit from Hewitt and a bully dog programmer. Can anyone tell me if this has worked for them? Or maybe they know someone that’s done this. All feed back is welcome.
     
  2. Feb 23, 2020 at 3:32 PM
    #2
    Johnsonman

    Johnsonman New Member

    Joined:
    Nov 25, 2019
    Member:
    #39132
    Messages:
    790
    Gender:
    Male
    Austin
    Vehicle:
    Sequoia
    LED headlamps/fogs; interior footlamps.
    Whoa there....

    What CEL code are we talking about that was cleared?
     
  3. Feb 23, 2020 at 3:44 PM
    #3
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    I don’t have it in front of me but best I remember it was P1445 or something like that. I’m at work so it will take me going home to get the printout.
     
  4. Feb 23, 2020 at 3:48 PM
    #4
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    It was the code for the secondary air value
     
  5. Feb 23, 2020 at 6:41 PM
    #5
    FXFormat

    FXFormat New Member

    Joined:
    Nov 13, 2018
    Member:
    #21669
    Messages:
    526
    Gender:
    Male
    That bypass kit works, install it and you'll never have to worry about it again. Plenty of us Land Cruiser owners have had it installed, very easy to do, look on youtube for DIY
     
    Formerchevyman [OP] likes this.
  6. Feb 23, 2020 at 9:34 PM
    #6
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    FXformat. Thanks for the info. I think I’m going to go ahead and get one.
     
  7. Feb 23, 2020 at 10:36 PM
    #7
    TTund16

    TTund16 New Member

    Joined:
    Jan 3, 2017
    Member:
    #5798
    Messages:
    853
    Gender:
    Male
    What is the problem and how can you clear it without fixing? I missed other threads about this issue.

    Can you give a quick summary?
    Thanks
     
  8. Feb 23, 2020 at 10:45 PM
    #8
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    Ok in summary. I started the truck this morning. (Around 1pm cause I work the owl shift) truck ran fine. Drove about 1 mile and stopped at a stop sign. When I pressed the gas it went into limp mode. Vsc light flashing and 4 Lo flashing. I pulled over and took the battery cable loose for 30 seconds. Re attached the positive post cable and started the truck. All lights were off and the truck ran fine.
     
    TTund16 likes this.
  9. Feb 23, 2020 at 10:49 PM
    #9
    TTund16

    TTund16 New Member

    Joined:
    Jan 3, 2017
    Member:
    #5798
    Messages:
    853
    Gender:
    Male
    isn't the CEL for secondary air valve coming back again? What is causing the code?
     
  10. Mar 5, 2020 at 4:02 PM
    #10
    Formerchevyman

    Formerchevyman [OP] New Member

    Joined:
    Oct 17, 2019
    Member:
    #37471
    Messages:
    7
    Gender:
    Male
    First Name:
    Shawn
    Vehicle:
    07 Tundra DC LTD
    6” RC lift. 35x12.50 BFG KO2
    So here’s the update. Got the Hewitt-Tech by-pass. Took it to my buddies shop and we installed it. Took about an hour only because he refuses to let his work look less than OEM. On startup. All codes cleared themselves. (P2440 was the code) truck runs great. Only about 20 miles on it right now. But I’ll be updating as I put more miles on it.
    Im pretty happy about this.
     
    Spaceiscool and Rph74 like this.

Products Discussed in

To Top