1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

KTJO 4x4 Auto Fold Mirror Harness Install

Discussion in '3rd Gen Tundras (2014+)' started by BamaMan44, Jun 7, 2020.

  1. Jun 7, 2020 at 1:38 PM
    #1
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Disclaimer

    Do not make this a thread about your experience with KTJO 4x4. Let's keep it to an install guide where people ask questions about the process. Thanks!

    ************************************

    Here is my write up on installing this harness. Overall, the install wasn't too bad. I did have some issues with the auto fold not working but she was extremely responsive and provided great support. She is going to send me a replacement kit when she gets it corrected. I will update this thread after I get the replacement kit.

    I took my time with this and tried to route the wires as nice as possible.

    Here are my truck details:

    2017 SR5 with 2013 Limited mirrors.

    Here are the kit contents.

    Kit.jpg

    Better break down of the kit in the pictures on her website.

    Driver side install

    Started with the driver side mirror. I remember seeing on this forum that the wiring was different on the mirrors from the 07-13 models but it doesn't seem that way.

    The Orange and Yellow Wires on Control Module: Orange = Unfold Yellow = Fold. The Blue Wire is connected to the Orange Wire and the Green Wire is connected to the Yellow Wire in the Harness. This means the following: Blue = Unfold Green = Fold. OEM Outer Mirror Connector is the following: Unfold (MR/MR+) = Pin 7 Fold (MF/MR-) = Pin 8.

    Installed the blue wire in the 8 pin position and the green wire in the 7 pin position. When I had them installed the other way, the mirrors would fold without pushing the button and fold with pushing the button. This will probably change when I get the new kit. Will update the thread if it does.


    IMG_2106.jpg

    Removed the panel on the side of the dash, panel below the steering wheel, driver side kick panel and driver side door panel. @2020Platinum has videos on how to do this. Hopefully you're okay with me tagging you.

    Routed the wire through the hole in the driver side kick panel leading out to the door jamb.

    IMG_2093.jpg

    Cut a hole in the grommet between the door and the cab to route the wires through. Highly recommend you use something to push through the hole and pull the wires through.

    IMG_2094.jpg

    Removed the speaker and routed the wires through the grommet above the speaker.

    IMG_2095.jpg
    IMG_2096.jpg

    Zip tied the wires to the wiring harness running to the mirror.

    IMG_2102.jpg

    Used the provided wiring pins and inserted them into the mirror connector. There's a small piece on top that you need to pull up that will make inserting the pins easier. If you can't push that piece down easy then the pins aren't fully seated.

    IMG_2106.jpg

    Passenger side install

    I removed the passenger side kick panel and routed the wire through the hole leading out to the door jamb.

    I cut a hole on the passenger side just like I did on the driver side.

    Routed the wires through the same area as the driver side. This time I sed mechanical fingers to pull the wires through. Made it a lot easier.

    IMG_2103.jpg IMG_2104.jpg

    Removed the passenger side vent and ran my mechanical fingers through there and grabbed the wires to rout through.

    I pulled them up behind the main wiring harness and routed them in front of the air bag mount. I then zip tied them to the two holes below.

    IMG_2107.jpg

    I then removed the center lower panel and ran the wires down to there.

    IMG_2108.jpg IMG_2109.jpg

    Then I routed the wires through to under the panel below the steering wheel.

    IMG_2110.jpg

    All of the plugs are pretty self-explanatory except for this one. It plugs into the blue on the bottom of the drive side kick panel.

    IMG_2111.jpg

    Right now I have the fuse tap plugged into the the sunroof fuse spot since I don't have a sunroof. I just have the wiring harnesses and module all zip tied together until I get the replacement kit.

    Let me know if you have any questions.
     
    Last edited: Jun 12, 2020
  2. Jun 7, 2020 at 2:41 PM
    #2
    mountainpete

    mountainpete Explore more, worry less.

    Joined:
    Oct 24, 2018
    Member:
    #20928
    Messages:
    848
    Alberta, Canada
    Vehicle:
    2018 Cement Crewmax TRD
    Function before sparkle.
    Awesome job. My kit is sitting waiting to clear Canada customs.

    Can you describe a bit more of the problem requiring a fix? Does the button work but the auto fold with the door locks not work?

    And any other recommendations for the install is appreciated! Once all the pieces come in my plan is to install this, FRAC and a Cali light bar all in one day.
     
    TundraTex and BamaMan44 [OP] like this.
  3. Jun 7, 2020 at 2:47 PM
    #3
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Thanks brother!

    When I pinned the plug based on her instructions, the mirrors would fold without pushing the button. When I pushed the button, they would unfold. So, I removed the pins and reversed them. They would not fold/unfold with the fob in either location. I contacted her and she said the harness was sired wrong and she will get it fixed and mail out replacements to the 8 people who had ordered them. Right not I can fold/unfold with the button, but they do not work with the fob.

    If you want to get the puddle lights and auto dim features to work, then do them the same times as you do this. I didn't and wish I had. Take your time and preplan your layout. completely remove the lower panel under the steering wheel so you have lots of room.
     
    BlueRibbon4x4 and mountainpete like this.
  4. Jun 7, 2020 at 3:09 PM
    #4
    mountainpete

    mountainpete Explore more, worry less.

    Joined:
    Oct 24, 2018
    Member:
    #20928
    Messages:
    848
    Alberta, Canada
    Vehicle:
    2018 Cement Crewmax TRD
    Function before sparkle.
    I wonder if I’m one of the 8 getting a new harness? @KTJO 4x4 can you advise?

    You got me thinking... maybe I should do the puddle lights. Too bad they weren’t part of the harness!
     
    BamaMan44 [OP] likes this.
  5. Jun 7, 2020 at 3:10 PM
    #5
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    I would wait if I were you. I probably will at some point, lol.
     
  6. Jun 7, 2020 at 3:37 PM
    #6
    mountainpete

    mountainpete Explore more, worry less.

    Joined:
    Oct 24, 2018
    Member:
    #20928
    Messages:
    848
    Alberta, Canada
    Vehicle:
    2018 Cement Crewmax TRD
    Function before sparkle.
    Thanks to Canada Post waiting is mandatory! But I only want to open this thing up once.

    For the puddle lights to activate on the OEM power folder, is it power to pin 6 right and then to the cargo lamp?

    I’m not a fan of auto dim so I don’t want to activate it.
     
  7. Jun 7, 2020 at 3:45 PM
    #7
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
  8. Jun 7, 2020 at 3:52 PM
    #8
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
  9. Jun 7, 2020 at 3:54 PM
    #9
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
  10. Jun 7, 2020 at 3:59 PM
    #10
    mountainpete

    mountainpete Explore more, worry less.

    Joined:
    Oct 24, 2018
    Member:
    #20928
    Messages:
    848
    Alberta, Canada
    Vehicle:
    2018 Cement Crewmax TRD
    Function before sparkle.
    BamaMan44 [OP] likes this.
  11. Jun 7, 2020 at 4:01 PM
    #11
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Yeah, man sorry. You're welcome!
     
  12. Jun 7, 2020 at 4:07 PM
    #12
    ARMYGREEN

    ARMYGREEN New Member

    Joined:
    Jul 29, 2019
    Member:
    #33866
    Messages:
    327
    Vehicle:
    2014 CrewMax MGM
    2010 FJ ArmyGreen 2014 FJ Iceberg
    I bought the kit and have not received it yet so hopefully mine is the fixed version.
     
    BamaMan44 [OP] and mountainpete like this.
  13. Jun 7, 2020 at 4:25 PM
    #13
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Hopefully so.
     
  14. Jun 7, 2020 at 6:31 PM
    #14
    chrisbusnut

    chrisbusnut New Member

    Joined:
    Sep 6, 2019
    Member:
    #35751
    Messages:
    248
    Gender:
    Male
    First Name:
    Chris
    Pasadena, CA
    Vehicle:
    2020 Tundra Crew Max SR5 4x4 w/TRD Off Road pkg
    DiamondBack bed cover, SDHQ sliders, SwitchPro, Katzkin leather seats, TRD Pro grille, TRD Pro wheels w/Nitto Ridge Grappers, Toyota OEM leather steering wheel, SSO Slimline Hybrid Bumper w/Baja Designs S8 light bar, Warn Zeon Platinum 10-S winch, Baja Design rock lights & flush mount rear bumper lights
    @BamaMan44 , GREAT post! Thanks for taking the time to do that and include photos. Very helpful and excellent instructions.

    I also received my harness this weekend and installed yesterday, however I ran into other issues. The add-a-fuse that she included with rage harness had 20 amp fuses in it. I plugged it into the HAZARD space in the fuse box, which is 15 amp. This is what I had discussed with her months ago, when I was testing the prototype harness. When I turned the hazards on, I got intermittent clicking out of her control module. So I contacted her and then moved the add-a-fuse to the DOME location (dome light), which is 10 amp. I also changed the fuses in the add-a-fuse to 10 amps. Once I did that and had everything connected, the drivers side mirror would fold and unfold, but the passenger mirror didn’t do a thing. I tried swapping the wires on the passenger mirror, and then they both stopped working. The control module is supposed to click when you press the fold button on the mirror switch, but it stopped making that noise, so I’m left to believe that the module is fried for some reason.

    I got frustrated and gave up. KTJO is supposed to send me the replacement harness, and a replacement module. I agree that she has been excellent to work with. She’s been patient with me when my patience tends to wear thin, which is a good thing.

    A few questions, @BamaMan44 , why did you have to cut holes in those grommets in the doors? Would the green & blue wire loom not fit through the rubber sleeve? Also, you mentioned sunroof space in fuse box. I don’t have a sunroof either and didn’t even see that space (I will have to look again). I’m assuming it has power, but probably not constant power, which is what you would need for the key fob to work. Did you try one of the fuses that has constant power? There aren’t many, but hazard and dome should be two. Did you leave the 20 amp fuses in the add-a-fuse?

    Thanks again for your excellent write up!
     
    BamaMan44 [OP] likes this.
  15. Jun 7, 2020 at 6:53 PM
    #15
    mountainpete

    mountainpete Explore more, worry less.

    Joined:
    Oct 24, 2018
    Member:
    #20928
    Messages:
    848
    Alberta, Canada
    Vehicle:
    2018 Cement Crewmax TRD
    Function before sparkle.
    Thanks for posting this. The module likely needs constant power so Hazard should have worked (but now it makes sense why sunroof might not as it has power after the engine goes off until the door is opened).

    Does the module require a 20 amp constant?
     
  16. Jun 7, 2020 at 7:22 PM
    #16
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    You're welcome!

    I didn't cut a new hole, I just made the one there bigger. So it was easier to route through the grommet.

    I tried a few different ones while I was chatting with her. I was never able to get it to work with the fob. I have a constant power running to a Switch for my lights in the front. So I took out the inline fuse and jumpered a wire from it to the power for my lights. Still didn't work.

    Yes, I just left the 20 amp fuses in there. Going to have to figure something else out though. I can't put my fuse cover on. I just have it in my center console. I also wired in my radar detector with a fuse tap as well so I may just leave them in and leave the fuse cover in the center console.
     
  17. Jun 7, 2020 at 7:23 PM
    #17
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    It does need constant power. I don't know about the amperage though.
     
  18. Jun 7, 2020 at 7:54 PM
    #18
    chrisbusnut

    chrisbusnut New Member

    Joined:
    Sep 6, 2019
    Member:
    #35751
    Messages:
    248
    Gender:
    Male
    First Name:
    Chris
    Pasadena, CA
    Vehicle:
    2020 Tundra Crew Max SR5 4x4 w/TRD Off Road pkg
    DiamondBack bed cover, SDHQ sliders, SwitchPro, Katzkin leather seats, TRD Pro grille, TRD Pro wheels w/Nitto Ridge Grappers, Toyota OEM leather steering wheel, SSO Slimline Hybrid Bumper w/Baja Designs S8 light bar, Warn Zeon Platinum 10-S winch, Baja Design rock lights & flush mount rear bumper lights
    I agree the hazard should have worked, but it was causing issues with the module when I turned the hazards on to test them. The module kept making an intermittent clicking noise, and this is before I connected the mirrors. It would click twice, then a second or two later, click twice again, and on and on. That’s only when I had the hazards on. Maybe there is a relay with the hazards that was causing an issue. And that probably contributed to my control module frying.

    One thing I’m not clear on, due to my ignorance on electrical systems, is the amperage of the fuses. If KTJO included 20 amps in the add a fuse, and I put the add a fuse into a space that has either 10 amp (DOME) or 15 amp (HAZARD), will that cause an issue? Do I need to replace the fuses in the add a fuse to match what was in the space I am using? I assumed so. There’s a reason Toyota is using a specific amperage on each fuse position, so I didn’t want to risk causing issues with the electrical system.

    As a side note, when I started the truck this morning, the nav screen and audio system were completely dead, and the USB charging ports are also dead. I started to check fuses, but couldn’t find anything in the owners manual that identified them, and the diagrams in the fuse box covers aren’t really clear. So I’m taking it to the dealer tomorrow and will let them deal with it. I’m sure it is somehow related to what I did yesterday, though I have no idea how. I obviously screwed something up.
     
  19. Jun 7, 2020 at 8:25 PM
    #19
    KTJO 4x4

    KTJO 4x4 New Member

    Joined:
    Jul 19, 2018
    Member:
    #17175
    Messages:
    107
    Gender:
    Female
    First Name:
    Katie
    Oregon
    Thank you so much for your write up!!!! You did such a great job!!! I apologize for my absence everyone. I will make a new thread tonight as I will not be granted my old threads back I have been informed. I must start over :annoyed:

    Everyone will be getting a new harness that has been sent out. There have been 8. I have a list. It has only been the orders that did not upgrade. Basically, you can connect everything and have the switch work right now but the auto function will not because the two wires are not communicating without the truck on. When the truck is off there is no power going to the switch. If you look at the control module connector you will see how one wire is going to the OEM side and one wire is going to the switch side. That is the reason they are not communicating. They both need to be going to the OEM side. This is being fixed as we speak.

    Please look for the new thread either tonight or tomorrow. I will get it up as soon as I can. Again, it was absolutely horrible timing and I do apologize for whatever took place, that it took place. I guess I missed whatever it was but maybe that’s a good thing. Less drama the better. Let this be a new thread with some great posts of some great installs photos. I can’t wait to see them. I have received some feedback as far as some tundras being different on the lock harness which I wonder how many there are and if I’m going to have to make a few different kits or what. Look forward to getting feedback on that one. Especially since my vendor is making this now. It would be great to hear this now.
     
    BamaMan44 [OP] and mountainpete like this.
  20. Jun 7, 2020 at 9:40 PM
    #20
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    You're welcome!

    Welcome back as well!
     
    KTJO 4x4 likes this.
  21. Jun 7, 2020 at 9:43 PM
    #21
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Did you check your RAD fuse? It probably got tripped.
     
  22. Jun 7, 2020 at 11:50 PM
    #22
    KTJO 4x4

    KTJO 4x4 New Member

    Joined:
    Jul 19, 2018
    Member:
    #17175
    Messages:
    107
    Gender:
    Female
    First Name:
    Katie
    Oregon
    BamaMan44 [OP] likes this.
  23. Jun 8, 2020 at 12:36 AM
    #23
    TRON

    TRON Is LIVE on the GRID.

    Joined:
    Jan 8, 2016
    Member:
    #2398
    Messages:
    662
    Gender:
    Male
    First Name:
    Stefen
    Gilbert, Arizona
    Vehicle:
    IG: @ST3F3NS
    DUROBUMPS Use TRON10 for 10% Off & Free Shipping
    subd! :popcorn:
     
    BamaMan44 [OP] likes this.
  24. Jun 8, 2020 at 6:44 AM
    #24
    2020Platinum

    2020Platinum www.youtube.com/NitroZ18Fishing

    Joined:
    Oct 30, 2019
    Member:
    #38029
    Messages:
    771
    Gender:
    Male
    First Name:
    Patrick
    Northeast PA
    Vehicle:
    2020 Platinum MGM
    4/2 ReadyLift SST, XF 220’s in 20x9 +12 wrapped in 35x12.5 Kenda Klever RT’s, TRD Pro Headlights, PowertraxOne XR Tonneau Cover, BedRug Bedliner, Blacked Out Emblems, Window Tint, Weathertech Window Deflectors, Pop N Lock Power Tailgate lock, LED Lighting Kit in Bed, Color Matched Mirror Caps/Door Handles, LED lighting inside cab
    No prob, glad my videos are helping people out!!...if anyone needs to see them my channel is www.youtube.com/NitroZ18Fishing
    Nice write up man!!
     
    BamaMan44 [OP] likes this.
  25. Jun 8, 2020 at 8:05 AM
    #25
    BamaMan44

    BamaMan44 [OP] Roll Tide Roll! Bama Fan till I die! & Go 'Hawks!

    Joined:
    Jul 15, 2019
    Member:
    #33261
    Messages:
    676
    Gender:
    Male
    First Name:
    Andre
    NorCal
    Vehicle:
    Trailbreaker - 2017 Black CrewMax SR5 4x4
    Thanks brother!
     
    2020Platinum likes this.
  26. Jun 11, 2020 at 2:36 PM
    #26
    fisherman951

    fisherman951 LT dreams ....

    Joined:
    Sep 12, 2017
    Member:
    #9616
    Messages:
    4,083
    Gender:
    Male
    First Name:
    Tony
    Riverside
    Vehicle:
    2017 crewmax 4x4
    Well what the hell happened to @KTJO??
     
  27. Jun 11, 2020 at 2:42 PM
    #27
    Pinay

    Pinay New Member

    Joined:
    Sep 14, 2018
    Member:
    #19379
    Messages:
    15,711
    Gender:
    Female
    First Name:
    Monet
    Vehicle:
    2015 Black - SR5 - CrewMax - 4x4 - TSS Dirty Seven Club
    Mahal kita Kuya
    Perma banned across all sites.

    Moderators tried to intervene on behalf of a member who paid her for goods that never arrived and she refused to answer any inquiries after being given time to explain herself.
     
  28. Jun 11, 2020 at 2:45 PM
    #28
    fisherman951

    fisherman951 LT dreams ....

    Joined:
    Sep 12, 2017
    Member:
    #9616
    Messages:
    4,083
    Gender:
    Male
    First Name:
    Tony
    Riverside
    Vehicle:
    2017 crewmax 4x4
    Wowsers she had some good items going on for our trucks.
     
    Dunchues likes this.
  29. Jun 11, 2020 at 2:53 PM
    #29
    TXTundra2722

    TXTundra2722 Pipe Hitters Union

    Joined:
    Nov 26, 2018
    Member:
    #22236
    Messages:
    1,264
    Gender:
    Male
    Texas
    Vehicle:
    2015 Black Tundra
    True... hope it was just a misunderstanding because she's offered alot of good products and really helped the Toyota community. Im sure if she hasn't answered the question she will soon.
     
  30. Jun 11, 2020 at 2:58 PM
    #30
    ColoradoTJ

    ColoradoTJ O'Keefe Music Foundation Staff Member

    Joined:
    Feb 24, 2016
    Member:
    #2766
    Messages:
    20,802
    Gender:
    Male
    First Name:
    Chris
    Colorado
    Vehicle:
    GMC 3500
    She still does, just will not be a part of this site.

    This might be hard for some to believe, but the staff does have the members best interests in mind.
     

Products Discussed in

To Top