1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Installed K&N Filter, now Check Engine light stays on and Traction Control off

Discussion in 'General Tundra Discussion' started by dekberg13, Jan 30, 2016.

  1. Jan 30, 2016 at 6:11 PM
    #1
    dekberg13

    dekberg13 [OP] New Member

    Joined:
    Jan 30, 2016
    Member:
    #2567
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2016 Tundra 4x4 (White)
    New to the forum and a new owner of a 2016 4x4.

    I just installed a K&N cold air intake and now my check engine light stays on and the center display says "Traction Control Off" repeatedly. I have shut off and the engine and restarted it and I have pressed the traction control button multiple times (turning it on and off with the button) but the center display shows the same thing both ways ("Traction Control Off").

    I disconnected the battery as noted in the K&N instructions. Not sure if killing the power caused the warning lights/indicators.

    Any ideas?

    Thanks!

    Darren
     
  2. Jan 30, 2016 at 6:21 PM
    #2
    Virgils12

    Virgils12 New Member

    Joined:
    Dec 21, 2014
    Member:
    #816
    Messages:
    929
    Gender:
    Male
    Vehicle:
    2012
    Camburg Fox factory 2.5" lift Xd monsters with 295/70/18 nitto terra graplerrs Corsa cat back Weather tech liners Wet okole covers
    You took the negative off?
     
  3. Jan 30, 2016 at 6:25 PM
    #3
    dekberg13

    dekberg13 [OP] New Member

    Joined:
    Jan 30, 2016
    Member:
    #2567
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2016 Tundra 4x4 (White)
  4. Jan 30, 2016 at 6:29 PM
    #4
    dekberg13

    dekberg13 [OP] New Member

    Joined:
    Jan 30, 2016
    Member:
    #2567
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2016 Tundra 4x4 (White)
    Yes it was the negative
     
  5. Jan 31, 2016 at 7:31 AM
    #5
    Sean266

    Sean266 #ThinBlueLine Staff Member

    Joined:
    Jan 5, 2014
    Member:
    #6
    Messages:
    10,928
    Gender:
    Male
    Colorado
    Did you see what the code reads?
     
  6. Feb 3, 2016 at 7:38 AM
    #6
    TruckLife900

    TruckLife900 All Eyez On Me

    Joined:
    Oct 29, 2015
    Member:
    #2033
    Messages:
    378
    Gender:
    Male
    Vehicle:
    2013 White SR5
    Maybe the air box didn't seal all the way back up when you had it apart? Check fitment?
     
To Top