1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Dash Warnings / See Dealer on Display

Discussion in '3rd Gen Tundras (2014+)' started by GbRunner10, May 14, 2019.

  1. May 14, 2019 at 4:01 PM
    #1
    GbRunner10

    GbRunner10 [OP] New Member

    Joined:
    Nov 27, 2018
    Member:
    #22277
    Messages:
    23
    Gender:
    Male
    First Name:
    Chris
    Hey guys!

    I recently had/going through an issue with my 18 Tundra over the weekend. On start up, the instant I went into drive... A bunch of warning lights came on and display warnings also.

    I’d like to start off saying that the truck is leveled with 5100’s and 1.5” block in the rear.

    The lights that are coming on are my 4 hi, 4 lo, ABS, brake system warning light, traction (solid) and the yellow warning explanation mark. Now for display warnings it comes up: Trailer brake malfunction see dealer, Pre collision malfunction see dealer, Drive start malfunction see dealer.

    Naturally I checked all my abs lines for power (ran into a pinched cable when I put the struts in) and all the lines were good and had power through them. I checked all my fuses and they were all good. Dropped off the truck to the dealer yesterday and they mentioned that there were two recalls. ECU software and the dreaded PCS issue. They flashed the ECU for the recall and the tech said that everything went out and was good. They didn’t perform the PCS recall due to the level.

    I go in town to pick up my truck and put it in drive... all the lights come back on. Shut it off to go tell them that the warnings are back on... Start the truck again, and everything was off. So I start heading home and THEN all the lights and warnings came back on. I left the truck there so they can investigate further.

    I know this is not a PCS error as the truck has worked fine since the level install. Also isn’t showing the PCS error stuff. My concern is the “Drive Start Malfunction”. With all my research I’ve only ever seen this come up once, someone had a similar issue.. but the thread died. Has anyone had any experience with these symptons. I have a strong suspicion that the dealer will quickly blame the level for the errors. It’s still under warranty, I just don’t want to get jerked around. I cant really bring it to another dealer.

    Thanks for the help!
     
  2. May 19, 2019 at 2:40 PM
    #2
    2chains

    2chains New Member

    Joined:
    Apr 27, 2019
    Member:
    #29708
    Messages:
    30
    Gender:
    Female
    This is just a shot in the dark. Have you put gas in it recently? I had a christmas tree of lights come on ie ABS/ATRAC/check engine /multi terrain control recently with my 4runner and was pretty concerned. I read up online and found one possible issue which was lack of pressure in the fuel system or something like that. When that happens the power shuts off to secondary systems. I was pretty skeptical of the solution but it mentioned that the gas cap has to be tightened fully past one click...I loosened and tightened and after the fourth start up it cleared on the dash. No issues since then.
     

Products Discussed in

To Top