1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Brake Light - 2011

Discussion in '2nd Gen Tundras (2007-2013)' started by Kbienk16, Feb 27, 2020.

  1. Feb 27, 2020 at 5:43 AM
    #1
    Kbienk16

    Kbienk16 [OP] New Member

    Joined:
    Feb 17, 2020
    Member:
    #42742
    Messages:
    3
    Gender:
    Male
    First Name:
    Kyle
    Vehicle:
    2011 Platium Tundra
    Other than the brake fluid being low or the parking brake is engaged, what are the other causes for the dash brake light to be on?
    I recently did a 2 inch lift (leveling kit) to the front and the light turned on unexpectedly. All brake functions feel normal; pedal, stopping ability, etc.
     
  2. Feb 27, 2020 at 5:55 AM
    #2
    Tundra234

    Tundra234 New Member

    Joined:
    Nov 30, 2018
    Member:
    #22402
    Messages:
    7,684
    Gender:
    Male
    First Name:
    George
    Florida
    Vehicle:
    2020 Tundra DC SR5 Barcelona
    Alot of them
    A leveling kit wont cause it to come on. Try setting and releasing the parking brake and see if it goes out.
     
  3. Feb 27, 2020 at 6:10 AM
    #3
    Kbienk16

    Kbienk16 [OP] New Member

    Joined:
    Feb 17, 2020
    Member:
    #42742
    Messages:
    3
    Gender:
    Male
    First Name:
    Kyle
    Vehicle:
    2011 Platium Tundra
    Yes, tried that several times. No success
     
  4. Feb 27, 2020 at 6:18 AM
    #4
    Tundra234

    Tundra234 New Member

    Joined:
    Nov 30, 2018
    Member:
    #22402
    Messages:
    7,684
    Gender:
    Male
    First Name:
    George
    Florida
    Vehicle:
    2020 Tundra DC SR5 Barcelona
    Alot of them
    Maybe disconnect the battery for a few minutes?
     
  5. Feb 27, 2020 at 12:44 PM
    #5
    Kbienk16

    Kbienk16 [OP] New Member

    Joined:
    Feb 17, 2020
    Member:
    #42742
    Messages:
    3
    Gender:
    Male
    First Name:
    Kyle
    Vehicle:
    2011 Platium Tundra
    Thanks, I just pulled the terminals and put them back on and it did the trick.
     
  6. Feb 27, 2020 at 2:21 PM
    #6
    TheBeast

    TheBeast The Beach

    Joined:
    Apr 27, 2016
    Member:
    #3246
    Messages:
    12,047
    Gender:
    Male
    SoCal
    Vehicle:
    2012
    read the codes next time it comes up.
     
  7. Feb 27, 2020 at 6:18 PM
    #7
    Tundra234

    Tundra234 New Member

    Joined:
    Nov 30, 2018
    Member:
    #22402
    Messages:
    7,684
    Gender:
    Male
    First Name:
    George
    Florida
    Vehicle:
    2020 Tundra DC SR5 Barcelona
    Alot of them
    :thumbsup: Hopefully it doesn't come back.
     
  8. Feb 28, 2020 at 11:11 AM
    #8
    RCdadfor2

    RCdadfor2 New Member

    Joined:
    Jan 17, 2020
    Member:
    #41319
    Messages:
    31
    Gender:
    Male
    First Name:
    Jeff
    Vehicle:
    2008 Tundra DC
    none yet
    Sometimes the sensor in the brake fluid reservoir goes bad need to change the reservoir. not hard to do and can be done with out bleeding the system. the other thing could be the brake switch on the actual brake pedal. on my previous truck i replace the switch first because cheap and easy. but ended up being the sensor so i changing the reservoir and it was fixed.
    It started intermittently coming on once a month or so and would reset every time I shut the truck off, towards the end it would come on right away as the sensor got worse.
     
  9. Mar 1, 2020 at 12:08 AM
    #9
    blackdemon_tt

    blackdemon_tt Battery Slayer

    Joined:
    Feb 27, 2020
    Member:
    #43241
    Messages:
    1,437
    Gender:
    Male
    Vehicle:
    2007 5.7l Tundra DC SR5 long bed 2wd
    TRD Sway Bar, Roll covers USA bed cover
    Happens to me all the time, I push the pedal up from the bottom of the pedal and it goes away. I sometimes do this repeatedly after first starting it and within 3-4 blocks after leaving my home.
     

Products Discussed in

To Top