1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Android Head Unit Review and Info

Discussion in 'Audio & Video' started by dud13, Oct 21, 2018.

?

Rating from people who have purchased this device (1=lowest, 10=highest)

  1. 10

    0 vote(s)
    0.0%
  2. 9

    0 vote(s)
    0.0%
  3. 8

    12.5%
  4. 7

    25.0%
  5. 6

    0 vote(s)
    0.0%
  6. 5

    50.0%
  7. 4

    0 vote(s)
    0.0%
  8. 3

    0 vote(s)
    0.0%
  9. 2

    0 vote(s)
    0.0%
  10. 1

    12.5%
  1. Oct 21, 2018 at 7:12 PM
    #1
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    Decided to add an informative type video and compile all the install information I know into one place to make it a little easier on people.

    I have a 2018 Tundra 1794 CrewMax and installed the v2 Fastboot version with knobs. Your mileage may vary on your year and model.

    I will edit this post with new information as it becomes available to consolidate for ease.

    Overall, there are some bugs and other issues but I’d rate it a 7 out of 10.
    • Sometimes the touchscreen doesn’t respond as well as I would like.
    • There is almost no technical support. You can call Phoenix direct, but its a crap shoot if you get a hold of anyone. The times that I did get someone on the phone though they were very helpful.
    • Only one of the two external USB connections seem to work. Maybe one is for something else? Check which one charges your phone before using. The other may not work.
    • I also had the unit crash on me once.... black screen with colored lines all over the place, freaked me out. Turned the truck off and on and it seemed to be ok after that.
    • The front and rear cameras are noticeably darker on this screen than the stock radio. They really need to have a screen brightness setting for the cameras.
    • The unit will freeze up sometimes when using the Waze navigation app. I haven't noticed any freezing with any other apps yet.
    • Sometimes the bluetooth music streaming from my iPhone won't have any sound coming from the truck. For some reason the "Music" volume resets to 0. I called Phoenix and they said it was a known bug.
    • Found a new one today. Apparently you can’t play any video through the video app as it’s “disabled for your safety”. Sound from the video files comes through with a gigantic ass screen that says go fuck yourself. If you want to watch movies or videos you’re SOL.
    DC6B03C5-C1E3-4E4A-8D2B-9F4D54084325.jpg 98F617E0-6E01-4F99-B0CE-E0AEF7D815F8.jpg
    • Serious lack of communication from the manufacturer and Phoenix about general settings for the head unit, any updates, bug fixes, etc... I should not have to create a Facebook account to get information.
    Video I put together with info, there is no sound.


    Removal of old Head Unit:


    There are no instructions for installation or connection of the wiring harnesses on the Android unit. However, they are “somewhat” easy to install. The connectors can only go in one way and are matched to each slot.

    The main wiring harness had these connections left over. The gray plug on the left is mislabeled, Im pretty sure it is the USB connection that goes below the radio, next to the cigarette lighters and alarm thing. The Red, White, and Yellow RCA cables are the AUX inputs. Don't know what the two white CAN connectors are for:
    5F1DDA62-5A1D-4212-A504-0B263B2E8DE8.jpg

    These are the CAN connections that I used, the front camera connection is a separate harness from the main, its one of the smaller ones like the USB, it goes just below CAN 3 (2 spots above the USB):
    B9E140A5-D42C-407B-9BBF-A0B1E7886D2F.jpg

    Another pic of the Front Camera connection. One of the yellow RCA connections is the Front, the other is for the Side cameras. Trial and error on which is which as they are not labeled:
    3837B5FD-B949-41E0-981E-12E7C6EB4938.jpg
    3F8FC172-9AA0-450E-9F9D-9067A2324BB9.jpg

    This is the Front camera I used:
    https://www.amazon.com

    I has some bright lights around it... supposedly it has great low light capabilities. I cut a piece of tape into a small circle and covered the middle and spray painted over the lights. I may get a different one with higher resolution as this one seems to be only 640x480. I’ll update on a new camera when it comes in.

    I used the GPS puck that came with the head unit, I ran it behind the dashboard to the drivers side door access panel and up through/behind the weatherstripping.

    IMG_1822.jpg

    Then followed the crack between the speaker grill and A arm

    IMG_1821.jpg

    If you want to use the stock GPS antenna with the truck, you will need the following (I may go back and do this myself):

    https://www.amazon.com
    and
    https://www.amazon.com

    The Android unit comes with a dual USB splitter. I ran one below the radio and through the old USB port that I removed (pretty much useless now that it was disconnected from the old stereo). Again, only one of the USB outputs from the HU seems to work. If both of yours work let me know. Mine may just be defective.

    IMG_1825.jpg

    The other I ran to the center console, this is where I plan on adding an external drive for music, movies, etc... I used a Dremel to make a hole for this adapter:

    https://www.amazon.com

    IMG_1824.jpg

    @BayRunner posted about the Harman Spark that you can use as a WIFI hotspot instead of your phone. Its through ATT and costs about $75 to purchase and $25 a month.

    https://www.att.com

    I’m a Verizon user and they have a version called Hum. It costs $120 for the device and $15a month for unlimited data. I used an OBD splitter with mine so I don't have to worry about loosing an OBD port:

    https://www.amazon.com

    Overall, not too bad. Like I said, some bugs and annoyances, but pretty good so far. If Phoenix utilized the comments/forums section that already exists on their website for instructions, updates, notices, etc... and kept it up to date, Im quite sure they would sell many, many more of these radios. I have a strong suspicion that many people keep clear of these radios mainly due to the reasons stated above.

    Recommendations for Phoenix and/or the manufacturer:
    • Phoenix: Answer your phone, emails, something, anything.
    • Phoenix: If you utilized your website more for common questions, answers, fixes, installation, etc... you wouldn't have as many phone calls.
    • Manufacturer: If you are going to make an app, that can be used on many devices, that can be used in many vehicles (which is what this setup is: An Android tablet running some version of Android OS [Not 7.0.1 like they state] with a couple apps to run various vehicle systems like AC, steering wheel controls, and OBD info) you need to make a "Setup" screen when first installing. This way the user can select what vehicle they have and only the settings that apply to their vehicle will show and many settings will automatically be adjusted depending on the vehicle the user chooses.
    • Phoenix and Manufacturer: Installation and User Instructions.
    • Phoenix and Manufacturer: Info, people need info. Not Facebook info either. Updates, bug fixes, how to, etc... Like I said, I think many people are staying away from this product because they hear many users with questions, complaints, etc....
    • Phoenix: More information on your website about the unit and accessories that work with it. I tried finding information on the TV tuner and CarPlay accessories and there is next to nothing. How does it work? Does it replace the existing OS on the Head Unit? Will the TV play while the vehicle is in motion, or is it like the Video App that doesn't seem to play movies AT ALL? Is the language in Chinese like in the photo?
    • Manufacturer: Add the ability to install an external WIFI antenna or fix the installed one, it has extremely poor reception. My laptop will pick up WIFI signals 5 houses away... the Android radio won't pick up the WIFI from my house while parked in the driveway.
    • Manufacturer: Add DVR/DashCam support for installed front, side, and rear cams.
     
    Last edited: Oct 27, 2018
  2. Oct 23, 2018 at 7:56 PM
    #2
    TundraER

    TundraER New Member

    Joined:
    Feb 25, 2018
    Member:
    #13152
    Messages:
    10
    Gender:
    Male
    Austin, TX
    Well done! Really nice initial write-up.
     
    TundraLuv likes this.
  3. Oct 24, 2018 at 7:05 AM
    #3
    TheBronze1

    TheBronze1 New Member

    Joined:
    Sep 12, 2017
    Member:
    #9610
    Messages:
    103
    Gender:
    Male
    First Name:
    Al.
    Maryland
    Vehicle:
    2017 bronze mica 1794
    bed cover, upgraded stereo system, light bar in hood and front grill, bed lights, switch back lights by step bars
    i will wait another year or so until they work all the simple bugs out.this unit should be able to work with all factory connections without having to modify wiring or adding any wiring even if they have to charge a bit more.
     
  4. Oct 24, 2018 at 7:24 AM
    #4
    Danny

    Danny New Member

    Joined:
    Aug 17, 2018
    Member:
    #18242
    Messages:
    47
    Gender:
    Male
    Vehicle:
    2018 Tundra Crewmax SR5
    I can’t find that same hu on eBay.. can you direct me on where to go please
     
  5. Oct 24, 2018 at 7:44 AM
    #5
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    ? eBay? Don’t know anything about eBay. There are some on Alibaba.com though. These are through Phoenix Android Radio and their website.
     
  6. Oct 24, 2018 at 7:47 AM
    #6
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    It's $550 (reg $900) until Oct 27/18 with code: tundra71gb. fb moderator says this is the last group buy as they are popular enough across several vehicles.

    Only select whether you want buttons or not under "Color"

    https://www.phoenixautomotiveinc.co...screen-navi-radio-for-toyota-tundra-2014-2018

    Beware it's not plug and play like a tried and true brand name HU. You have to like tinkering and put up with any issues, figuring out the settings etc

    Screen Shot 2018-10-24 at 10.44.59 AM.jpg
     
  7. Oct 24, 2018 at 7:50 AM
    #7
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    Thanks for this thread OP! Is there a way to play video for the other passengers? And even bluetooth some headphones?

    I'll add my rating/comments when I get mine!
     
  8. Oct 24, 2018 at 11:27 AM
    #8
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    No worries. Just put this together mostly to help the people on the new group buy and the ones that haven’t received theirs from the last group buy.

    I haven’t hooked up external monitors to see if the video will play through those yet. I know that videos will not play through the head unit at all. I’m hoping there is a setting that changes this restriction. I’ll update when I find out.
     
  9. Oct 24, 2018 at 11:58 AM
    #9
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    I wonder what the limitation is? I remember I bypassed it in the wiring of an Infiniti I used to have making everything available out of Park.
     
  10. Oct 24, 2018 at 12:32 PM
    #10
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    Even in park it won’t play video.
     
  11. Oct 24, 2018 at 12:51 PM
    #11
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    Well that’s odd because I’ve seen people put up screenshots of stored movies, Netflix and IPTV. Wiring? Has it ever?
     
  12. Oct 24, 2018 at 1:42 PM
    #12
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    You can play videos off the internet or YouTube. But you can’t play downloaded movies through the movie/video app. You get a giant warning screen that says video disabled for your safety.

    68F04764-CA35-41F4-8F9F-982430F54842.jpg
     
    Last edited: Oct 24, 2018
    JoshuaA likes this.
  13. Oct 24, 2018 at 3:13 PM
    #13
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    Gotcha, have you tried another video player apk? Can you store vids in the ROM? Strange streaming video will work but local won’t.
     
  14. Oct 24, 2018 at 3:45 PM
    #14
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    streaming video goes through google chrome explorer. the video player app has a restriction put on it somehow. if you use the file explorer and open a video file with one of the other apps it plays fine, just not the video app that is on the screen. and without the ability to customize or add apps to the screen its a bit cumbersome to play them.
     
    JoshuaA likes this.
  15. Oct 28, 2018 at 3:51 PM
    #15
    Wvrktguy

    Wvrktguy New Member

    Joined:
    Oct 28, 2018
    Member:
    #21053
    Messages:
    3
    Gender:
    Male
    First Name:
    Wes
    Vehicle:
    2014 Tundra TRD
    Awesome info. Thank you for taking the time to do this. I just decided to pull the trigger on one.
     
  16. Oct 28, 2018 at 4:27 PM
    #16
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    My kids have been watching downloaded youtube vids and a movie stored on separate USB thumbs driving around all day via the Video App on the main screen (film reel icon), I haven't seen that safety message at all. They are mp4's.

    Maybe try switching the yellow RCA to the other yellow one?
     
  17. Oct 28, 2018 at 4:40 PM
    #17
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.
    I’ll give it a go and see what happens. Though I don’t know if that will work. It’s an internal file that I am playing from a thumb drive that I have a bunch of mp3 files stored on as well and those play fine. Currently when I play a move from an attached thumb drive I can hear the movie and when I go from full screen to smaller screen the video pops up for a second then disappears.
     
  18. Oct 28, 2018 at 5:59 PM
    #18
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    That’s weird, I also have mp3’s on my USB. Since it’s a software Safety Warning, could it be buried in the Developer Settings not allowing it? PW=666888

    Side note, took me a few tries before the Netflix app would install. I went through the browser to sign into NF first as the apk kept saying corrupt with the installer.

    43DC19E0-811E-405D-853B-1CCC45F87E67.jpg
     
    TundraLuv likes this.
  19. Oct 28, 2018 at 6:10 PM
    #19
    JoshuaA

    JoshuaA I'm a cowboy, on a steel horse I ride

    Joined:
    Dec 15, 2017
    Member:
    #11529
    Messages:
    1,561
    Southern Ontario
    I don’t have that Toyota Security input underneath the HU, it’s a blank switch. That’s where I pulled through the USB line.

    The other USB line I tunneled into the glove box. Removing the filter cover, it’s a direct passthrough behind the dash, no drilling holes.

    177B9192-F72D-474B-9805-AB093BBFCEC8.jpg

    Do you get the error on both ports. You’ve tried various mp4’s? Maybe it’s inherent in the truck itself because you have TSS.
     
  20. Oct 28, 2018 at 6:24 PM
    #20
    dud13

    dud13 [OP] níl aon tinteán mar do thinteán féin

    Joined:
    Aug 27, 2018
    Member:
    #18663
    Messages:
    361
    Gender:
    Male
    Vehicle:
    2018 MGM 1794 4WD 5.7 (noFFV)
    See Info Page DeChroming... in progress.

    Don’t know yet. I looked in the advanced settings and can’t find anything. I’ll try again tomorrow and update.
     
To Top