1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2105 Tundra TRD ECU Issues?

Discussion in '3rd Gen Tundras (2014+)' started by Pckroid, May 12, 2019.

  1. May 12, 2019 at 4:15 PM
    #1
    Pckroid

    Pckroid [OP] New Member

    Joined:
    May 12, 2019
    Member:
    #30457
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2015 Tundra TRD
    I have this 2015 Tundra and it sat for a month or so and wasn't run much over the winter here in PA. Once I started it, the check engine, traction control and 4L & 4H were flashing. It runs fine, except you cannot shift into 4 wheel. I reset the ECU, checked fuses and found nothing. Any ideas what my problem might be? Bought this as a second owner, never had any issues with it for well over a year and has only 42,000 miles on it.
     
  2. May 12, 2019 at 4:34 PM
    #2
    NewImprovedRon

    NewImprovedRon "220, 221- WHATEVER IT TAKES" - Michael Keaton

    Joined:
    Jul 8, 2015
    Member:
    #1501
    Messages:
    10,868
    Gender:
    Male
    First Name:
    Ron
    Bentonville, AR
    Vehicle:
    2015 Radiant Red TSS Doublecab 4X4 Off Road
    Deck rail system, Bed divider, door sill protectors, LED reverse light bars, Aries Bull Bar with 28" 180 watt LED light bar, LED step lights, LED bed lights, driver-side grab handle, TRD Rear Sway Bar, BedRug bed mat and tailgate mat, Morimoto Fog Lights, more to come.....
    Was it inside a garage or outside? I wonder if it is possible you have a rogue rodent that chewed on some wiring?
     
    Black Wolf likes this.
  3. May 12, 2019 at 5:08 PM
    #3
    Blueknights75

    Blueknights75 WHITE is the FASTEST color!!!!!

    Joined:
    May 13, 2018
    Member:
    #15276
    Messages:
    2,937
    Gender:
    Male
    First Name:
    Ron
    Raleigh, NC
    Vehicle:
    18’ SUPER WHITE SR5 TRD CM
    Rugged 2 tri fold tonneau cover, spray in bed liner, bed extender, window tint, color matched side mirrors, color matched door handles, TRD Pro shift knob, tailgate keyfob actuator, ESP under seat storage unit mod, blacked out emblems, Toyota OEM black exhaust tip, color matched front and rear bumper caps from Sparks Parts, TRD Air filter, 19’ PRO BBS wheels...more to come
    Welcome from NC!
     
  4. May 15, 2019 at 9:35 AM
    #4
    Pckroid

    Pckroid [OP] New Member

    Joined:
    May 12, 2019
    Member:
    #30457
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2015 Tundra TRD
    Ii was out of town and finally got to take a good look at my Tundra. Yes, it does sit outside and I have had issues with critters before. Today I had it up on ramps and really looked. I did find a wire off at a plug that goes into the module near the gas tank. It was the red wire. I cannot determine if it was critters or not so I posted a picture. But the story is interesting. After repairing, the flashing 4L & 4H lights went off but I still had the check engine and traction control. I reset the ECU again, no help. I decided to drive it some and see if that makes any difference. Yes, the traction control went off and now I only have the check engine light. Everything is working as it should. I am in the process of doing a battery disconnect reset right now and see if that makes a difference. I'll be away for a few days but will report back on my findings and the inevitable solution. Thanks to all.

    0.jpg
     
    Black Wolf and NewImprovedRon like this.
  5. May 16, 2019 at 11:31 AM
    #5
    Pckroid

    Pckroid [OP] New Member

    Joined:
    May 12, 2019
    Member:
    #30457
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2015 Tundra TRD
    I went to Autozone and had the codes read. P0453 evporative emission system pressure sensor/switch high input. I am researching this today.
     
    Black Wolf likes this.
  6. May 16, 2019 at 11:40 AM
    #6
    Black Wolf

    Black Wolf AMAROK, Inuit Stealthy Mythical Beast

    Joined:
    Apr 20, 2014
    Member:
    #378
    Messages:
    25,857
    Gender:
    Male
    First Name:
    Matt
    Aurora CO
    Vehicle:
    2014 Attitude Black Metallic/Barcelona Red hybrid 5.7L DC Limited TRD 4X4
    None
    Do you always top of your tank when filling up? If so....you shouldn't. Can cause evap system issues.
     
    NewImprovedRon likes this.

Products Discussed in

To Top