1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

2000 Tundra 4.7 2wd missing

Discussion in '1st Gen Tundras (2000-2006)' started by superberry111, Dec 16, 2015.

  1. Dec 16, 2015 at 8:02 AM
    #1
    superberry111

    superberry111 [OP] New Member

    Joined:
    Dec 16, 2015
    Member:
    #2267
    Messages:
    2
    Gender:
    Male
    HI i have a 2000 toyota tundra 4.7 2wd but it will misfire really bad at idle and anything under 2500 rpms but there is no check engine light coming on at all. took it to the dealer ship and they said its the exhaust. I just put new tail pipe on it cause the old dual exhaust rusted off. Before i but just a single pipe on it, it ran like a scolded dog. Also when cold it white smokes heavly. Im thinking it may be the computer. truck has 183,000 any suggestions would be appreciated thanks
     
  2. Dec 16, 2015 at 2:27 PM
    #2
    alalmcgrath

    alalmcgrath New Member

    Joined:
    Aug 11, 2015
    Member:
    #1646
    Messages:
    147
    Gender:
    Male
    First Name:
    Al
    Boulder Creek Ca
    Vehicle:
    2011 DC 4.6L
    White smoke = tranny fluid or coolant
     
  3. Dec 16, 2015 at 5:38 PM
    #3
    LOTSOFTOYS

    LOTSOFTOYS New Member

    Joined:
    Jun 9, 2015
    Member:
    #1396
    Messages:
    1,045
    Gender:
    Male
    First Name:
    Jace
    Mile high
    Vehicle:
    2005 Tundra DBL cab
    Highly doubt it's the computer. No check engine light tho? If it's truly misfiring it would set a code....
     
  4. Dec 16, 2015 at 9:17 PM
    #4
    superberry111

    superberry111 [OP] New Member

    Joined:
    Dec 16, 2015
    Member:
    #2267
    Messages:
    2
    Gender:
    Male
    Well that's what stumped me it mis fires on almost all cylinders until u rev it up over 2500 and sometimes will idle just fine then just cut out completely kind of like its flooding its self any ideas ... And yes there is no check engine light on
     
  5. Dec 17, 2015 at 11:22 AM
    #5
    LOTSOFTOYS

    LOTSOFTOYS New Member

    Joined:
    Jun 9, 2015
    Member:
    #1396
    Messages:
    1,045
    Gender:
    Male
    First Name:
    Jace
    Mile high
    Vehicle:
    2005 Tundra DBL cab
    Huh.... pinch the return line, does it get worse?
     
To Top