1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Help with Baja Designs Fog Lights

Discussion in 'Lighting' started by Jrharvey02, Dec 8, 2018.

  1. Dec 8, 2018 at 3:08 PM
    #1
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    So, I ordered the BD Squadron Sports (Amber) during their Black Friday sale, along with the wiring harness for my 2nd gen tundra. I just got done installing the first fog lamp and I thought I’d make sure it works, so I turn on the truck and the BD fog doesn’t work but the factory fog on the other side does work...

    I quickly disassemble the other factory fog light and plug the other BD fog light into my trucks wiring harness and no lights on either of the BD fogs?

    I can plug my old fog lights in and they work. I can hardwire the BD fogs directly to a battery and they work, but when I use the harness for my tundra, nothing.

    What the hell am I missing? Plug and play right? I didn’t use any of the wiring that came with the lights (splitter and switch), just the harness for the 2nd gen that plugs into the back of the BD and that plugs directly into my trucks wiring harness...anybody have any ideas? I did do the anytime fog light mod weeks ago, I don’t think that has anything to do with it...thanks
     
  2. Dec 8, 2018 at 3:16 PM
    #2
    TheBeast

    TheBeast The Beach

    Joined:
    Apr 27, 2016
    Member:
    #3246
    Messages:
    12,050
    Gender:
    Male
    SoCal
    Vehicle:
    2012
    the BD lights probably require more juice than the stock ones. if you use the provided harness, does it work ?
     
    Black Wolf likes this.
  3. Dec 8, 2018 at 3:25 PM
    #3
    crochetjohn

    crochetjohn IG: latrdpro

    Joined:
    Sep 28, 2017
    Member:
    #9955
    Messages:
    227
    Gender:
    Male
    South Louisiana
    Vehicle:
    2015 Inferno TRD Pro
    There should be a pigtail they provide that you have to pin out. In the instructions it states to test it to make sure you have the + and - the correct way before locking down the pigtail.
     
    Black Wolf and NewImprovedRon like this.
  4. Dec 8, 2018 at 3:27 PM
    #4
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    I just got them to both work by installing the harness “up-side-down”. The problem with this is the harness’ don’t click and lock now. They must have reversed the wires when assembling. WTF, should I just press them in as firmly as possible and electrical tape the shit out of them? I don’t really like harness’ not locking shut...
     
  5. Dec 8, 2018 at 3:32 PM
    #5
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    Here’s the 2nd gen harness they provided that is apparently backwards. Am I supposed to somehow take this apart and switch the red/black wires? I don’t see how to disassemble without breaking the shit out of it?
     
  6. Dec 8, 2018 at 3:33 PM
    #6
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    Here’s the harness with the reversed wiring

    76EB2FA8-26D8-4A87-A302-B62C6AF5A651.jpg
     
  7. Dec 8, 2018 at 3:36 PM
    #7
    crochetjohn

    crochetjohn IG: latrdpro

    Joined:
    Sep 28, 2017
    Member:
    #9955
    Messages:
    227
    Gender:
    Male
    South Louisiana
    Vehicle:
    2015 Inferno TRD Pro

    It's flip-able. There's a door you swing out from the side. It's held by two notchcs on the side. Then you should be able to push the pins out.

    I use the same style connectors for all my stuff on my truck. https://www.amazon.com/gp/product/B01FP1HXHQ/ref=oh_aui_search_detailpage?ie=UTF8&psc=1

    shows more of how they disassemble
     
  8. Dec 8, 2018 at 3:52 PM
    #8
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    I can get the “door” to swing away, but the wires are still solidly in there. Do I just yank on the red and black wires to try and pull them out of there to? They don’t wanna come out by giving them a good tug and I’m really hesitant to pull more
     
    TheBeast and crochetjohn like this.
  9. Dec 8, 2018 at 3:56 PM
    #9
    crochetjohn

    crochetjohn IG: latrdpro

    Joined:
    Sep 28, 2017
    Member:
    #9955
    Messages:
    227
    Gender:
    Male
    South Louisiana
    Vehicle:
    2015 Inferno TRD Pro
    There are two wings that pop out but usually you can just pull. Maybe get a small flathead and push them down while pulling. There is a special tool for pushing the pins down but a small flathead should work.
     
  10. Dec 8, 2018 at 4:35 PM
    #10
    NewImprovedRon

    NewImprovedRon Hey! Get off my grass!

    Joined:
    Jul 8, 2015
    Member:
    #1501
    Messages:
    13,240
    Gender:
    Male
    First Name:
    Ron
    Bentonville, AR
    Vehicle:
    2015 Radiant Red TSS Doublecab 4X4 Off Road
    Deck rail system, Bed divider, door sill protectors, LED reverse light bars, Aries Bull Bar with 28" 180 watt LED light bar, LED step lights, LED bed lights, driver-side grab handle, TRD Rear Sway Bar, BedRug bed mat and tailgate mat, Morimoto Fog Lights, more to come.....
  11. Dec 8, 2018 at 4:47 PM
    #11
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    Thanks! That’s what I was looking for. Unfortunately already tried to just yank and ended up pulling the wire away from the metal connector. Got it back together though. Now I know what to do with the other side, hopefully much less of a PITA. Was this a defect in BD assembly or what? Why am I having to take things apart that are supposed to be plug and play?
     
  12. Dec 8, 2018 at 6:30 PM
    #12
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    Absolutely nothing in my instructions regarding pinning out anything to determine +\-.

    And I didn’t need a pigtail, unless you mean the additional $60 wiring harness that plugs directly into my existing fog harness that I used.
     
  13. Dec 8, 2018 at 7:39 PM
    #13
    Jrharvey02

    Jrharvey02 [OP] New Member

    Joined:
    Sep 25, 2018
    Member:
    #19822
    Messages:
    1,118
    Gender:
    Male
    Colorado
    Vehicle:
    2010 Tundra CM 5.7 Platinum Dark Black
    Reversed polarity...found a dude with an identical issue buried within the BD general discussion. Thanks for everybodies help who chimed in.
     
    MotoTundra likes this.
  14. Dec 9, 2018 at 5:32 AM
    #14
    andy9743

    andy9743 New Member

    Joined:
    Sep 8, 2016
    Member:
    #4466
    Messages:
    628
    Gender:
    Male
    First Name:
    andrew
    nw ohio
    Vehicle:
    08 tundra cm 4x4 trd sc, +2 pulley, 4.88s, 37's, other things
    I had to do this as well. Repinned and all good for 2 years
     
  15. Dec 9, 2018 at 7:30 AM
    #15
    BlueBottle

    BlueBottle not a PRO

    Joined:
    Sep 17, 2016
    Member:
    #4572
    Messages:
    5,088
    Vehicle:
    '16 Platinum 4x4
    See fine print
    Mine came with that connector uninstalled. I had to insert the pins myself the correct way.
     
    NewImprovedRon likes this.

Products Discussed in

To Top