1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

USB port works intermittently

Discussion in '2.5 Gen Tundras (2014-2021)' started by Fishin1981, May 18, 2017.

  1. May 18, 2017 at 4:22 AM
    #1
    Fishin1981

    Fishin1981 [OP] New Member

    Joined:
    Feb 12, 2017
    Member:
    #6328
    Messages:
    137
    Gender:
    Male
    Vehicle:
    2015 tundra limited crewmax
    Pop and lock, esp storage, access lorado, front tints
    My USB port under the radio seems to work when it wants. Sometimes if it's not charging my phone I turn the truck off and on and it's back to working. Any ideas why this might happen? Also, what is the "security"? Can that be removed and replaced with another switch?
     
    Last edited: May 18, 2017
  2. May 18, 2017 at 6:54 AM
    #2
    040Tundra

    040Tundra Teddy 2013-2019

    Joined:
    Nov 13, 2016
    Member:
    #5188
    Messages:
    3,809
    Gender:
    Male
    First Name:
    Aaron
    Las Vegas, NV
    Vehicle:
    040 '16 CM LTD 4x4
    A little of this and a little of that.
    The USB sounds like it could be just a loose wire. As far as the Security light, I wouldn't take it out personally, but I don't see why not. If you need more switched why don't you put them on the underneath side, right above the USB and 12V?
     
  3. May 18, 2017 at 12:34 PM
    #3
    Fishin1981

    Fishin1981 [OP] New Member

    Joined:
    Feb 12, 2017
    Member:
    #6328
    Messages:
    137
    Gender:
    Male
    Vehicle:
    2015 tundra limited crewmax
    Pop and lock, esp storage, access lorado, front tints
    I'm not an electrician but a loose wire doesn't make sense. I literally turn the car off and on and then it will work.
     
  4. May 18, 2017 at 4:03 PM
    #4
    TXRailRoadBandit73

    TXRailRoadBandit73 TOYOTA,RAILROADER,RÖKNROLLN',BEER,BACON,FURBABIES

    Joined:
    May 30, 2016
    Member:
    #3487
    Messages:
    48,722
    Gender:
    Male
    First Name:
    Adam
    RGV, TEXAS
    None yet
    How bought getting some pliers in give a small light squeeze to the usb cord end??? So it makes good contact to usb port
     
  5. May 22, 2017 at 5:19 PM
    #5
    Steve Tundra

    Steve Tundra New Member

    Joined:
    Nov 30, 2016
    Member:
    #5395
    Messages:
    356
    Gender:
    Male
    First Name:
    Steven
    Vehicle:
    2022 4x4 platinum
    Yeah this happens to me as well. I think it has to do with over drawing power. I have to do the same thing by restarting my truck and then it works fine. Not sure what the deal is there.
     
  6. Oct 4, 2018 at 6:35 PM
    #6
    Tornado Bones

    Tornado Bones New Member

    Joined:
    Oct 4, 2018
    Member:
    #20179
    Messages:
    5
    Gender:
    Male
    Vehicle:
    2016 Tundra 4x4 5.7
    Same issue in my 2016 tundra 4x4. Power seems to have a mind of it's own. Lately, it's not working much at all. Its affecting both front cigarette lighter ports, the front usb port and the lighter port in the back seat. Fuses are fine. As many comments as I'm seeing online, Toyota must be aware there is an issue. I travel a lot internationally so I dont have time to wander over to a service department to leave my truck for a couple of weeks or wait half a day in the service dept to fix my lighter. Appreciate any advice from the rest of you on this thread!!
     
  7. Oct 4, 2018 at 7:02 PM
    #7
    ninjajay

    ninjajay Posting from the toilet

    Joined:
    Dec 28, 2017
    Member:
    #11787
    Messages:
    2,055
    Gender:
    Male
    First Name:
    Jason
    Spoolston, TX
    Vehicle:
    2018 MGM 1794 TRD 4x4
    Toytec/Radflo Lift, Ambit RS02 18x9+0, Bridgestone Revo 3 295/70/18
    have you tried a shorter usb cable?
     
  8. Mar 5, 2019 at 8:19 PM
    #8
    tee1000

    tee1000 New Member

    Joined:
    Mar 5, 2019
    Member:
    #27142
    Messages:
    2
    Vehicle:
    2010 Tundra Crewmax
    I have similar issues on my 2010: All 3 outlets turn off and on repeatedly no matter what is plugged in, almost like a relay every 10-ish seconds. Anyone else seen this or have updates?
     
  9. Mar 5, 2019 at 8:29 PM
    #9
    TomyTun

    TomyTun New Member

    Joined:
    Oct 28, 2016
    Member:
    #5016
    Messages:
    471
    Gender:
    Male
    CA
    Vehicle:
    2016 TRD Off Road, Crewmax, 5.7L Non-FFV
    None
    I had a similar issue using an Amazon cheapo USB cord. I fixed the problem by switching to an Apple cord. Might be worth a shot for you to try.
     
    15whtrd likes this.
  10. Mar 13, 2019 at 2:27 PM
    #10
    tee1000

    tee1000 New Member

    Joined:
    Mar 5, 2019
    Member:
    #27142
    Messages:
    2
    Vehicle:
    2010 Tundra Crewmax
    Thanks Ron! I was using a stock Verizon USB 3.0 cable for Android. I got some (seemingly) better quality ones from Anker and they seem better. Still happens once in a while but it's not all the time like it was with the other cable.

    Anker USB C Cable, [2-Pack 3Ft] Premium Nylon USB-C to USB-A Fast Charging Type C Cable, for Samsung Galaxy S9/ S8/ Note 8, Ipad Pro 2018, LG V20/ G5/ G6, Pixel 2 XL, and More(Black)
    Sold by: AnkerDirect
     
    Watt maker likes this.
  11. Mar 13, 2019 at 2:36 PM
    #11
    15whtrd

    15whtrd Mr. Blonde

    Joined:
    Sep 20, 2015
    Member:
    #1829
    Messages:
    9,388
    Gender:
    Male
    First Name:
    Sean
    SoCal
    Vehicle:
    White 2015 Tundra DC SR5 TRD 4x4 5.7L, White 2003 Sequoia 2WD
    TRD Pro suspension, +2 Coachbuilder shackles, 2015 TRD Pro headlights, 20% ceramic tinted windows, clear ceramic tinted front windshield, aFe drop in pro s dry air filter, TRD airflow accelerator, TRD oil fill cap, TRD 18 psi radiator cap, BDX Bullydog tuner, Weathertech floor mats front and rear, rear seat fold down mod, DNA hard trifold tonneau cover, Linex with uv protection, TRD rear swaybar, TRD center caps, TRD Pro grille insert with color matching surround and bulge, TRD PRO headlights, aluminum oil filter canister, Real truck tailgate seal, Pop-n-lock tailgate lock actuator, rear diff breather relocate, RCI front skid plate. 275/70 R18 BFG KO2s
    Is there a relay for the outlets or is it just a fuse? Maybe try replacing the fuse for the hell of it. If it’s a relay maybe try swapping it with another one similar. Just throwing it out there.
     

Products Discussed in

To Top