1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

Factory trailer brake controller

Discussion in 'Towing & Hauling' started by derekmills02, Jun 28, 2018.

  1. Jun 28, 2018 at 8:58 AM
    #1
    derekmills02

    derekmills02 [OP] New Member

    Joined:
    Jun 27, 2018
    Member:
    #16513
    Messages:
    2
    Gender:
    Male
    First Name:
    Derek
    Vehicle:
    2018 Tundra SR5
    Has anybody had trouble with the factory trailer brake controller? All the lights work but it flashes trailer disconnected, then the warning goes away but brakes don't work.
     
  2. Jun 28, 2018 at 9:05 AM
    #2
    TRDProLife

    TRDProLife New Member

    Joined:
    Jan 19, 2017
    Member:
    #6026
    Messages:
    252
    Gender:
    Male
    St.Louis
    Vehicle:
    Barcelona Red Metallic TRD Pro Tundra
    Window Tint, ICI Magnum Steps, firestone spring helpers for towing.
    Sounds like you probably have some problems with the trailer (wiring) not the truck.
     
  3. Jun 28, 2018 at 9:06 AM
    #3
    TRDProLife

    TRDProLife New Member

    Joined:
    Jan 19, 2017
    Member:
    #6026
    Messages:
    252
    Gender:
    Male
    St.Louis
    Vehicle:
    Barcelona Red Metallic TRD Pro Tundra
    Window Tint, ICI Magnum Steps, firestone spring helpers for towing.
    If you can try a known good trailer maybe rent a uhaul trailer
     
  4. Jun 28, 2018 at 4:19 PM
    #4
    texasrho83

    texasrho83 Teacher in a Tundra

    Joined:
    Mar 30, 2017
    Member:
    #7025
    Messages:
    219
    Gender:
    Male
    First Name:
    Charles
    Conroe TX
    Vehicle:
    2016 DC MGM 4x4
    Readylift 6” Fox 2.5 coils to 8" 2” Pro Comp Add-a-leaves Fabtech UCAs BMC 35" Super Swamper Cobalts 20x10 - 24 XD825 DAP tuned Dual Powerstick Mufflers Smoked Cab Lights Galaxy 33HML CB Firestik antennas Rago flag mounts Tow mirrors 42" grill light bar Rock Lights (8)
    I've never noticed mine detecting a trailer...
     
  5. Jul 2, 2018 at 7:29 AM
    #5
    urbanj5

    urbanj5 New Member

    Joined:
    Jul 2, 2018
    Member:
    #16645
    Messages:
    3
    Vehicle:
    Tundra2018
    My 2018 Tundra has similar issues. Brake/turn signal lights work. Flashes trailer disconnected but when stopped and brakes fully applied the green trailer icon is displayed along with the brake gain setting. Upon accelerating the disconnection warning appears again and nothing displayed on LCD screen until fully stopped again. Toyota dealer say everything okay with truck. RV dealer (2018 Rockwood Roo) checked trailer and it also checked okay. I am considering an after market fix but hear there is a possible software fix. Anyone have experience with this?
     
    JJGarcia8 likes this.
  6. Jul 2, 2018 at 9:09 AM
    #6
    nishibot

    nishibot New Member

    Joined:
    Aug 20, 2017
    Member:
    #9170
    Messages:
    412
    Gender:
    Male
    First Name:
    Steve
    Perris, CA.
    Vehicle:
    2017 Tundra CM 4x4 TRD Off Road MGM
    I had same issue. Does it display disconnected when first plugged in or only after driving for a bit? If yes then its the trailer. My trailer ended up having a bad wheel sensor only happened when warm.
    Also do a search on this forum there is a lot of info on this exact problem
     
  7. Jul 2, 2018 at 10:30 AM
    #7
    urbanj5

    urbanj5 New Member

    Joined:
    Jul 2, 2018
    Member:
    #16645
    Messages:
    3
    Vehicle:
    Tundra2018
    Displays right from the get go.
     
  8. Jul 4, 2018 at 1:19 PM
    #8
    DvH297

    DvH297 New Member

    Joined:
    May 27, 2018
    Member:
    #15648
    Messages:
    5
    Gender:
    Male
    First Name:
    Derek
    Vehicle:
    2018 CrewMax SR5 TRD O/R 4x4
    My 2018 TRD 4x4 same. Mostly the 'trailer disconnected' warning is on any time i try to use the brake (lever). I've had the system work for a few seconds, but then right back to 'disconnected'.
    Still searching for a resolution. I bought the truck to tow and I want to take advantage of all the neat dash controls.
     
  9. Jul 4, 2018 at 3:01 PM
    #9
    urbanj5

    urbanj5 New Member

    Joined:
    Jul 2, 2018
    Member:
    #16645
    Messages:
    3
    Vehicle:
    Tundra2018
    I have researched on several forums and this seems to be a common problem with Tundras as well as other truck brands. The RV tech also corroborated this. Going to have an after market system installed as I don’t want to spend my camping season screwing around with this. A few friends that have trucks without this feature tell me the after market systems are superior. Too bad one of the reasons we liked this truck was because of the IBS. Love it in every other aspect though.
     
  10. Jul 10, 2018 at 8:55 AM
    #10
    JOEYIVI

    JOEYIVI New Member

    Joined:
    Jul 10, 2018
    Member:
    #16903
    Messages:
    2
    Gender:
    Male
    I am a service manager at a Toyota dealership and we just pulled our hair out with one of these. We replaced the brake controller the rear plug, but it ended up being the trailer brake ecu. I hope this helps someone else that is having the same problem. The ecu is located behind the glove box. You have to do a little disassembly to get to it.
     
    757TUNDRA likes this.
  11. Jul 13, 2018 at 10:08 AM
    #11
    KeithD

    KeithD New Member

    Joined:
    Jul 10, 2018
    Member:
    #16914
    Messages:
    4
    Gender:
    Male
    First Name:
    Keith
    Vehicle:
    2018 Tundra
    SR5 4x4 Trd Off-Road
    Hi JOEYIVI, appreciate any help on this... same issue, my truck is at the dealer and they are telling me the 2018 does not have a trailer brake ecu? You wouldn't happen to know the part number of the 2018 trailer brake ecu? Id like to pass it on to the dealer so they can get the correct fix. Thanks in Advance!
     
  12. Jul 13, 2018 at 10:40 AM
    #12
    AmateurWheels

    AmateurWheels New Member

    Joined:
    Jul 5, 2018
    Member:
    #16731
    Messages:
    3
    Gender:
    Male
    Vehicle:
    2018 Tundra TRD Sport CMAX, 2016 4Runner TRD PRO
    Bed Rug, Rails, TRD Exhaust Console Vault, Console OCD, V1, Bed Extender, Husky Exact Contour, WT TechShade
    Experiencing the same issue on my 2018 TRD Sport Crewmax 4x4 5.7 Flex. With a single axle trailer that has brakes. I've yet to try it with my other trailer that is dual axle brake. Works perfect on my '16 4Runner with a Prodigy P3 controller. I've captured video of it occurring and sent it to my local dealer last night, waiting to hear back from them. I will update the forum when I find out more. For those that are experiencing the issue, does your trailer have single axle brake or ? It may be helpful to gather more information here to see if it is only common to a particular trailer configuration.

    Further reading reveals other mfgs having a similar issue with integrated controllers. One F150 forum member I found added a load resistor to his trailer wiring to resolve the issue. Other reading was pointing to brakes being wired in serial vs parallel or vice versa. Perhaps some other Googling ideas that might help us solve the mystery together.
     
  13. Jul 13, 2018 at 10:47 AM
    #13
    JOEYIVI

    JOEYIVI New Member

    Joined:
    Jul 10, 2018
    Member:
    #16903
    Messages:
    2
    Gender:
    Male
    The part number we replaced was 89547-0C020
     
  14. Jul 13, 2018 at 10:48 AM
    #14
    KeithD

    KeithD New Member

    Joined:
    Jul 10, 2018
    Member:
    #16914
    Messages:
    4
    Gender:
    Male
    First Name:
    Keith
    Vehicle:
    2018 Tundra
    SR5 4x4 Trd Off-Road
    Thank You !!!
     

Products Discussed in

To Top