1. Welcome to Tundras.com!

    You are currently viewing as a guest! To get full-access, you need to register for a FREE account.

    As a registered member, you’ll be able to:
    • Participate in all Tundra discussion topics
    • Transfer over your build thread from a different forum to this one
    • Communicate privately with other Tundra owners from around the world
    • Post your own photos in our Members Gallery
    • Access all special features of the site

After-market radio issues

Discussion in 'Audio & Video' started by phrozenice06, Jun 4, 2018.

  1. Jun 4, 2018 at 2:40 PM
    #1
    phrozenice06

    phrozenice06 [OP] New Member

    Joined:
    Jun 4, 2018
    Member:
    #15886
    Messages:
    5
    Gender:
    Male
    First Name:
    Gary
    Vehicle:
    2010 tundra crew max tdr
    Hey there, I have just bought my first truck ever and I made it a 2010 Tundra Crew Max. I wanted to change the stock radio to a touch screen. So I bought a Kenwood DMX7704s with all the brain to hook up to my steering wheel. A couple of days later, the radio started to shut off and back on. It started doing this every 8 to 10 minutes. So I called crutchfield and they sent me the next version up and it still does the same thing. I change the brains that talk to the truck and made sure everything was properly connect and still keep happening. Can anyone give me a couple of tips? I really appreciate the help.
     
  2. Jun 4, 2018 at 2:48 PM
    #2
    Danimal86

    Danimal86 What's a Dickfir?

    Joined:
    Aug 29, 2017
    Member:
    #9321
    Messages:
    1,523
    Gender:
    Male
    First Name:
    Daniel
    Sacramento, CA
    Vehicle:
    2017 White Tundra SR5
    Welcome!

    Couple questions:
    When you say "brain" do you mean the Maestro integration kit?
    Is it shutting off 8-10 min like clockwork, or is it when you hit a bump?
     
  3. Jun 4, 2018 at 2:52 PM
    #3
    phrozenice06

    phrozenice06 [OP] New Member

    Joined:
    Jun 4, 2018
    Member:
    #15886
    Messages:
    5
    Gender:
    Male
    First Name:
    Gary
    Vehicle:
    2010 tundra crew max tdr
    Yes, the integration module. And I can be sitting still and it still turn off like it it rebooting itself. Almost like u are turning the truck off then back on. Its so frustrating and crutchfield can't even tell me anything.
     
  4. Jun 4, 2018 at 2:55 PM
    #4
    Danimal86

    Danimal86 What's a Dickfir?

    Joined:
    Aug 29, 2017
    Member:
    #9321
    Messages:
    1,523
    Gender:
    Male
    First Name:
    Daniel
    Sacramento, CA
    Vehicle:
    2017 White Tundra SR5
    Thats a bummer. There are plenty of people here with kenwood decks with the maestro kit. Hopefully they will chime in.

    Since they replaced the deck, i wonder if its the Maestro module shorting it out when it cycles.
     
  5. Jun 4, 2018 at 2:57 PM
    #5
    phrozenice06

    phrozenice06 [OP] New Member

    Joined:
    Jun 4, 2018
    Member:
    #15886
    Messages:
    5
    Gender:
    Male
    First Name:
    Gary
    Vehicle:
    2010 tundra crew max tdr
    Crutchfield even sent me a new one and I change it out as well with no help. Thanks though....
     
  6. Jun 4, 2018 at 3:31 PM
    #6
    ninjajay

    ninjajay Posting from the toilet

    Joined:
    Dec 28, 2017
    Member:
    #11787
    Messages:
    739
    Gender:
    Male
    First Name:
    Jason
    Houston, Tejas
    Vehicle:
    2018 MGM 1794 TRD 4x4
    Exterior LEDs, Pioneer 4200NEX, iDatalink Maestro, Ambit RS02, Nitto Ridge Grappler
    First thing I'd do is check for loose connections in the harness
     
  7. Jun 4, 2018 at 3:44 PM
    #7
    TFT

    TFT New Member

    Joined:
    Jan 15, 2018
    Member:
    #12242
    Messages:
    49
    Gender:
    Male
    First Name:
    Troy
    Vehicle:
    2017 Tundra Limited
    Where is it located, is it overheating?

    (I don't know anything about this specific system)
     
  8. Jun 5, 2018 at 12:13 AM
    #8
    phrozenice06

    phrozenice06 [OP] New Member

    Joined:
    Jun 4, 2018
    Member:
    #15886
    Messages:
    5
    Gender:
    Male
    First Name:
    Gary
    Vehicle:
    2010 tundra crew max tdr
    Hey ninjajay, the harness is fully secured, I had crutchfield put it together. The wiring was check thoroughly. TFT, I don't seem to have a overheating problem. I just placed it where the factory radio was. It just terrible to have a great radio and can't listen to it.
     

Products Discussed in

To Top